Jump to content

Archived

This topic is now archived and is closed to further replies.

xfezz

phpmyadmin: how to set up configuration storage to enable extended features?

Recommended Posts

Im running on windows Vista, installed the latest version of apache, php and mysql. Now I have phpadmin running but I get this message when I log in.

 

The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. To find out why click here.

 

I have been googling for the past hour because i'd like to enable these features. I have been only coming up with vague answers on how to set this up.  I'm more of a beginner so I need some help!

 

Share this post


Link to post
Share on other sites

I have been reading through the manual. I gave it a go but I ended up screwing something up. I deleted my phpadmin folder and started over fresh because I didnt know what I screwed up. The manual doesnt really list everything out in step by step order.  I need something thats dumbed down for a newbie. From what I gather I need to create a control user for phpmyadmin, give it rights and then setup a new database for phpmyadmin to use for the advanced features? Is there a certain order in which I need to do this? I dont even know how to go about this.

Share this post


Link to post
Share on other sites

This is what I did to enable the advanced features (using the latest version 3.4.x)

 

First login to phpmyadmin and create a new database called phpmadmin. When you have created the database select the import tab at the top of the page. Click the Browse/Choose file button and navigate to your phpmyadmin folder and open the scripts directory and select the create_tables.sql file. Click open to close the window. Then press Go (bottom of page). The database for the control user has been setup.

 

Next to setup the control user. Go to the phpmyadmin home screen and click the privileges tab. Click the add a new user link. For the username type phpmyadmin. Set anything as the password (Make sure you remember it). Choose the option to Create database with same name and grant all privileges And then click the Go button.

 

You have now setup the control user and the database for phpmyadmin. You now need to configure phpmyadmin. Open the config file (called config.inc.php). And remove the // from the start of the following lines

/* User used to manipulate with storage */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* Storage database and tables */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
// $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';

 

Make sure you set $cfg['Servers'][$i]['controluser'] to phpmyadmin and apply the password to $cfg['Servers'][$i]['controlpass']. Log out of phpmyadmin, then log back in (not as the control user). The advanced features should now be enabled.

Share this post


Link to post
Share on other sites

wildteen88, I followed your instructions to the T. After reading it just clicked in my head on what I had to do. Everything was set and done. Logged out and I was greeted to phpmyadmin not being able to read my config file.  Then I remember reading someone had the same problem and it was fixed by clearing out the browsers cache.  Once I did that everything was golden. Thanks a bunch.

 

Maybe a mod can put this in a tutorial for setting up phpmyadmin's advanced features. Very helpful!

 

Once again thanks!

Share this post


Link to post
Share on other sites

Hello there guys i am newbie...So, i feel totally dump the last 2 days...I've installed phpmyadmin(3.4.5) via wamp server and i get this message :

"The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. To find out why click here."

When i press here, ALL the options are NOT OK and DISABLED...

I've followed the instructions of wildteen88.

First of all this code he posted doesn't even exist in config.inc.php file :

 

/* User used to manipulate with storage */

// $cfg['Servers'][$i]['controluser'] = 'pma';

// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

 

/* Storage database and tables */

// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

// $cfg['Servers'][$i]['relation'] = 'pma_relation';

// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';

// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';

// $cfg['Servers'][$i]['history'] = 'pma_history';

// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';

// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

// $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';

 

What i did was to copy the code and pasted it to the config.inc.php and of course remove the " // ".

When i refreshed and cleaned the browser's cache i lost the view of phpmyadmin administration and some code above was displayed instead.

When i erased the code from the file everything got back.

What should i do....???

Share this post


Link to post
Share on other sites

i figured it out this might help every 1 that has this problem go to xampp/phpmyadmin folder an find config.inc.php an change this to (1) it maybe set to (0) like mine was n i put it at 1 n it cleared everything up now i have NO ERRORS on my phpmyadmin. Hope this helps. Enjoy!!!!! Im goin bac to finish up on my phpmyadmin if any 1 has any ? feel free to email me at curtis@barrettdiesel.com 

/*

* Servers configuration

*/

$i = 1;

Share this post


Link to post
Share on other sites

I forgot to tell you that i had 2 errors on my phpmyadmin

(1)The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated

(2)Connection for controluser as defined in your configuration failed.

So if you do what i posted then the problem will be fixed

Share this post


Link to post
Share on other sites

I have had this problem as well in Firefox, but out of curiosity I tried it in IE and the error does not show.

 

Im not sure if the extras work yet or how to check if they do so could someone give me some more info of how to see if all is good.

 

I changed the server value to 0 like the other post said but this didnt work.

 

Hope I helped someone.

 

VoodooJai

Share this post


Link to post
Share on other sites

i followed the instructions above and then had the messages:

 

(1)The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated

(2)Connection for controluser as defined in your configuration failed.

 

i tried the suggestions above and changed:

/* Servers configuration */
$i = 0;

to

/* Servers configuration */
$i = 1;

and cleared my cache, reloaded broswer, restarted service and now no databases or tables show in phpMyAdmin. 

 

using latest wampserver package on chrome. 

Share this post


Link to post
Share on other sites

Can someone here tell me how can I enable the advanced features to get rid of this message.

 

The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. To find out why click here.

 

 

Is this documented somewhere?Please let me know.

 

Thanks,

Ajit :

Share this post


Link to post
Share on other sites

Hello there guys i am newbie...So, i feel totally dump the last 2 days...I've installed phpmyadmin(3.4.5) via wamp server and i get this message :

"The phpMyAdmin configuration storage is not completely configured, some extended features have been deactivated. To find out why click here."

When i press here, ALL the options are NOT OK and DISABLED...

I've followed the instructions of wildteen88.

First of all this code he posted doesn't even exist in config.inc.php file :

 

/* User used to manipulate with storage */

// $cfg['Servers'][$i]['controluser'] = 'pma';

// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

 

/* Storage database and tables */

// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

// $cfg['Servers'][$i]['relation'] = 'pma_relation';

// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';

// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';

// $cfg['Servers'][$i]['history'] = 'pma_history';

// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';

// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

// $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';

 

What i did was to copy the code and pasted it to the config.inc.php and of course remove the " // ".

When i refreshed and cleaned the browser's cache i lost the view of phpmyadmin administration and some code above was displayed instead.

When i erased the code from the file everything got back.

What should i do....???

 

Can someone guide me with this issue.I have been facing the same problem.I dont have the above lines in my config.inc.php file.OPlease let me know?

 

Thanks,

Ajit

Share this post


Link to post
Share on other sites

hello ajit,

how did you resolve the problem the above code is also not existing in my config.inc.php file. Could you please tell me about procedure did you follow.

thanks

Share this post


Link to post
Share on other sites

I am another newbie and had the same problem. I have a user 'pma'. I have set up a database 'phpmyadmin' and populated it using the script create_tables.sql. All the tables are there in the database. So far so good.

 

Then in config.inc.php I inserted the following text which I copied from config.sample.inc and then edited (I put in the actual password for user pma in place of the asterisks).

 

/*

* phpMyAdmin configuration storage settings.

*/

 

/* User used to manipulate with storage */

$cfg['Servers'][$i]['controlhost'] = '';

$cfg['Servers'][$i]['controluser'] = 'pma';

$cfg['Servers'][$i]['controlpass'] = '********';

 

/* Storage database and tables */

$cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';

$cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';

$cfg['Servers'][$i]['relation'] = 'pma_relation';

$cfg['Servers'][$i]['table_info'] = 'pma_table_info';

$cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';

$cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';

$cfg['Servers'][$i]['column_info'] = 'pma_column_info';

$cfg['Servers'][$i]['history'] = 'pma_history';

$cfg['Servers'][$i]['table_uiprefs'] = 'pma_table_uiprefs';

$cfg['Servers'][$i]['tracking'] = 'pma_tracking';

$cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';

$cfg['Servers'][$i]['userconfig'] = 'pma_// $cfg['Servers'][$i]['recent'] = 'pma_recent';

/* Contrib / Swekey authentication */

$cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';

 

I saved the edited config.inc.php and restarted phpMyAdmin and the error message had disappeared. Bingo!

 

I hope that this helps people. I am using phpMyAdmin 3.5.5, which is the current one. Windows 7.

Share this post


Link to post
Share on other sites

I'm new to this and had the above problems even after following the posted solutions, but found that in my case an extra change to config.inc.php was needed. I believe that the issue only arises if you have more than one server defined, hence why the solutions above work for some, but not others.

 

If I understand correctly $i is an index to an array of server information and is intialised as below;

 * Servers configuration
$i = 0;

 

Then for each server it's incremented by a line containing, $i++;

 

In my case I have 2 servers, localhost, and a test server.

 

So for localhost $i = 1, and for the test server $i = 2.

 

The lines added to the ini file for configuration storage come after the lines for the servers so at this point $i is still 2, but I want it set up for localhost, not my testserver.

 

So I added $i = 1 as shown below.

 

 * phpMyAdmin configuration storage settings.
 */
$i = 1;

 

This worked for me, I hope it helps others.

Share this post


Link to post
Share on other sites

 

This is what I did to enable the advanced features (using the latest version 3.4.x)

 

First login to phpmyadmin and create a new database called phpmadmin. When you have created the database select the import tab at the top of the page. Click the Browse/Choose file button and navigate to your phpmyadmin folder and open the scripts directory and select the create_tables.sql file. Click open to close the window. Then press Go (bottom of page). The database for the control user has been setup.

 

Next to setup the control user. Go to the phpmyadmin home screen and click the privileges tab. Click the add a new user link. For the username type phpmyadmin. Set anything as the password (Make sure you remember it). Choose the option to Create database with same name and grant all privileges And then click the Go button.

 

You have now setup the control user and the database for phpmyadmin. You now need to configure phpmyadmin. Open the config file (called config.inc.php). And remove the // from the start of the following lines

/* User used to manipulate with storage */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* Storage database and tables */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
// $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
Make sure you set $cfg['Servers'][$i]['controluser'] to phpmyadmin and apply the password to $cfg['Servers'][$i]['controlpass']. Log out of phpmyadmin, then log back in (not as the control user). The advanced features should now be enabled.

 

thanks wildteen88 i followed the instructions, it worked. 

Share this post


Link to post
Share on other sites

step 1 open config.inc.php

step 2  past this and edit password to $cfg['Servers'][$i]['controlpass'] = 'your_passwor';

<?php
/* vim: set expandtab sw=4 ts=4 sts=4: */
/**
 * phpMyAdmin sample configuration, you can use it as base for
 * manual configuration. For easier setup you can use setup/
 *
 * All directives are explained in documentation in the doc/ folder
 *
 * @package PhpMyAdmin
 */
 
/*
 * This is needed for cookie based authentication to encrypt password in
 * cookie
 */
$cfg['blowfish_secret'] = 'a8b7c6d'; /* YOU MUST FILL IN THIS FOR COOKIE AUTH! */
 
/*
 * Servers configuration
 */
$i = 0;
 
/*
 * First server
 */
$i++;
/* Authentication type */
$cfg['Servers'][$i]['auth_type'] = 'cookie';
/* Server parameters */
$cfg['Servers'][$i]['host'] = 'localhost';
$cfg['Servers'][$i]['connect_type'] = 'tcp';
$cfg['Servers'][$i]['extension'] = 'mysqli';
$cfg['Servers'][$i]['compress'] = false;
$cfg['Servers'][$i]['AllowNoPassword'] = true;
 
/*
 * phpMyAdmin configuration storage settings.
 */
 
/* User used to manipulate with storage */
// $cfg['Servers'][$i]['controlhost'] = '';
$cfg['Servers'][$i]['controluser'] = 'root';
$cfg['Servers'][$i]['controlpass'] = 'your_passwor';
 
/* Storage database and tables */
 $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
 $cfg['Servers'][$i]['bookmarktable'] = 'pma__bookmark';
 $cfg['Servers'][$i]['relation'] = 'pma__relation';
 $cfg['Servers'][$i]['table_info'] = 'pma__table_info';
 $cfg['Servers'][$i]['table_coords'] = 'pma__table_coords';
 $cfg['Servers'][$i]['pdf_pages'] = 'pma__pdf_pages';
 $cfg['Servers'][$i]['column_info'] = 'pma__column_info';
 $cfg['Servers'][$i]['history'] = 'pma__history';
 $cfg['Servers'][$i]['table_uiprefs'] = 'pma__table_uiprefs';
 $cfg['Servers'][$i]['tracking'] = 'pma__tracking';
 $cfg['Servers'][$i]['designer_coords'] = 'pma__designer_coords';
 $cfg['Servers'][$i]['userconfig'] = 'pma__userconfig';
 $cfg['Servers'][$i]['recent'] = 'pma__recent';
  $cfg['Servers'][$i]['users'] = 'pma__users';
 $cfg['Servers'][$i]['usergroups'] = 'pma__usergroups';
 $cfg['Servers'][$i]['navigationhiding'] = 'pma__navigationhiding';
/* Contrib / Swekey authentication */
// $cfg['Servers'][$i]['auth_swekey_config'] = '/etc/swekey-pma.conf';
 
/*
 * End of servers configuration
 */
 
/*
 * Directories for saving/loading files from server
 */
$cfg['UploadDir'] = '';
$cfg['SaveDir'] = '';
 
/**
 * Defines whether a user should be displayed a "show all (records)"
 * button in browse mode or not.
 * default = false
 */
//$cfg['ShowAll'] = true;
 
/**
 * Number of rows displayed when browsing a result set. If the result
 * set contains more rows, "Previous" and "Next".
 * default = 30
 */
//$cfg['MaxRows'] = 50;
 
/**
 * disallow editing of binary fields
 * valid values are:
 *   false    allow editing
 *   'blob'   allow editing except for BLOB fields
 *   'noblob' disallow editing except for BLOB fields
 *   'all'    disallow editing
 * default = blob
 */
//$cfg['ProtectBinary'] = 'false';
 
/**
 * Default language to use, if not browser-defined or user-defined
 * (you find all languages in the locale folder)
 * uncomment the desired line:
 * default = 'en'
 */
//$cfg['DefaultLang'] = 'en';
//$cfg['DefaultLang'] = 'de';
 
/**
 * default display direction (horizontal|vertical|horizontalflipped)
 */
//$cfg['DefaultDisplay'] = 'vertical';
 
 
/**
 * How many columns should be used for table display of a database?
 * (a value larger than 1 results in some information being hidden)
 * default = 1
 */
//$cfg['PropertiesNumColumns'] = 2;
 
/**
 * Set to true if you want DB-based query history.If false, this utilizes
 * JS-routines to display query history (lost by window close)
 *
 * This requires configuration storage enabled, see above.
 * default = false
 */
//$cfg['QueryHistoryDB'] = true;
 
/**
 * When using DB-based query history, how many entries should be kept?
 *
 * default = 25
 */
//$cfg['QueryHistoryMax'] = 100;
 
/*
 * You can find more configuration options in the documentation
 * in the doc/ folder or at <http://docs.phpmyadmin.net/>.
 */
?>

Share this post


Link to post
Share on other sites

We are in year 2014 and this still work. Credits to @wildteen8. :happy-04:

 

 

My current setup:

Server version: 5.5.38

Microsoft-IIS/8.5

phpMyAdmin: Version information: 4.2.7 (up to date)

 

Cheers

 

This is what I did to enable the advanced features (using the latest version 3.4.x)

First login to phpmyadmin and create a new database called phpmadmin. When you have created the database select the import tab at the top of the page. Click the Browse/Choose file button and navigate to your phpmyadmin folder and open the scripts directory and select the create_tables.sql file. Click open to close the window. Then press Go (bottom of page). The database for the control user has been setup.

Next to setup the control user. Go to the phpmyadmin home screen and click the privileges tab. Click the add a new user link. For the username type phpmyadmin. Set anything as the password (Make sure you remember it). Choose the option to Create database with same name and grant all privileges And then click the Go button.

You have now setup the control user and the database for phpmyadmin. You now need to configure phpmyadmin. Open the config file (called config.inc.php). And remove the // from the start of the following lines

/* User used to manipulate with storage */
// $cfg['Servers'][$i]['controluser'] = 'pma';
// $cfg['Servers'][$i]['controlpass'] = 'pmapass';

/* Storage database and tables */
// $cfg['Servers'][$i]['pmadb'] = 'phpmyadmin';
// $cfg['Servers'][$i]['bookmarktable'] = 'pma_bookmark';
// $cfg['Servers'][$i]['relation'] = 'pma_relation';
// $cfg['Servers'][$i]['table_info'] = 'pma_table_info';
// $cfg['Servers'][$i]['table_coords'] = 'pma_table_coords';
// $cfg['Servers'][$i]['pdf_pages'] = 'pma_pdf_pages';
// $cfg['Servers'][$i]['column_info'] = 'pma_column_info';
// $cfg['Servers'][$i]['history'] = 'pma_history';
// $cfg['Servers'][$i]['tracking'] = 'pma_tracking';
// $cfg['Servers'][$i]['designer_coords'] = 'pma_designer_coords';
// $cfg['Servers'][$i]['userconfig'] = 'pma_userconfig';
Make sure you set $cfg['Servers'][$i]['controluser'] to phpmyadmin and apply the password to $cfg['Servers'][$i]['controlpass']. Log out of phpmyadmin, then log back in (not as the control user). The advanced features should now be enabled.

 

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.