Jump to content

Archived

This topic is now archived and is closed to further replies.

jones15

Unable to connect to mysql database

Recommended Posts

I installed php 5.1.4, Apache 2.2.2 and mysql 5 on a Fedora Core 5 server.

Everything works independently.  I even have phpMyAdmin working fine.  I finally figured out how to get the --with-mysql in the ./configure list (instead of --without-mysql). 

Yet when I try the mysql_connect command with a host, username and password, I get an error that it can't connect to the database and it doesn't even use the defined username/password. 

It says :  Access denied for user 'apache'@'localhost' (using password: YES).

Where did apache come from?  I don't have it anywhere in my code and its not written anywhere in my php.ini file.

Why doesn't it respect my username!?!

Share this post


Link to post
Share on other sites
You have not set the correct permissions for the apache username to connect to  MySQL

You need to setup permissions for the apache username.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.