Jump to content


Photo

Image Opacity


  • Please log in to reply
2 replies to this topic

#1 Skatecrazy1

Skatecrazy1
  • Members
  • PipPipPip
  • Advanced Member
  • 126 posts
  • LocationSouthern California

Posted 17 October 2006 - 03:58 AM

Alright, well first, look at this layout http://www.snapskate.com/v2/

well when I try to make my XHTML and CSS validity images appear at 50% opacity until they are hovered over, by using something like this:

img.xhtml {

opacity:.50;
filter: alpha(opacity=50);
-moz-opacity: 0.5;
}

img.xhtml:hover {

opacity:.100;
filter: alpha(opacity=100);
-moz-opacity: 1.0;
}

now, before I added this CSS, the css validated perfectly.

Now i get errors from the validator saying that the properties don't exist.  however, the hover opacity for the image, as you can see, works fine.

has anyone here done it a different way that is valid in CSS?
fuck it or fight it

#2 AndyB

AndyB
  • Staff Alumni
  • Advanced Member
  • 5,465 posts
  • LocationToronto

Posted 17 October 2006 - 11:30 AM

http://www.elementar...ced-errors.html

The problem is that the validator itself isn't 'up to date' with CSS standards.
Legend has it that reading the manual never killed anyone.
My site

#3 Skatecrazy1

Skatecrazy1
  • Members
  • PipPipPip
  • Advanced Member
  • 126 posts
  • LocationSouthern California

Posted 17 October 2006 - 11:20 PM

oh well that's depressing... is that something they know about and are trying to fix? (at w3c)
fuck it or fight it




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users