Jump to content

Archived

This topic is now archived and is closed to further replies.

SammyP

PHP install fails to execute scripts

Recommended Posts

I have a problem which I believe is fairly common but I cannot get past it. I am a fairly experienced PHP developer but have always done the work on my site's host and basically tried everything live. Now I want to be able to develop on my laptop without an internet connection as I'm going to be travelling.

I don't want to host a site from my laptop, but I believe it makes little difference, in that I still need to have a web server running on it to get PHP to work.

So I have XP Pro and fairly easily got IIS up and running. I downloaded the PHP 4.4.4 zip package and tried to follow all of the instructions. I've added the php directory to the PATH variable, edited the recommended php.ini file with some of the variables required, and gone to the web server and added a directory to the php.exe file to handle the .php extension.

I think I've done a few other things as well. I am unsure as to whether I want to use the CGI option or the ASAPI one it goes on about, but I've been following the CGI instructions.

I go to a web browser and get it to point to "http://localhost" and it opens up the default windows ASP file happily. I added a sam.php file to the directory with a simple echo statement and it fails giving me this error:

[quote]You have attempted to execute a CGI, ISAPI, or other executable program from a directory that does not allow programs to be executed.[/quote]

Seems fairly self explanatory so I've tried to fix it on my own, and then googled the error and found loads of solutions which don't work.

I have gone into IIS and found my Web Server element and found the properties tab and gone into Home Directory and told it to allow Scripts and Executables, though I don't see why this would work, as I think the problem is not with the web server's home directory but the PHP directory. Still, it was not only a suggested solution to getting this error, but also had replies thanking it as it had worked.

I have also used windows explorer to change the properties of the php folder to get it to allow scripts and executables, even though nobody said to do that.

I still get the error despite a reboot after every new attempts. Someone else must have had this happen before, though I haven't managed to find a query here anywhere.

Can anyone enlighten me?

Sam.







Share this post


Link to post
Share on other sites
OK, doesn't seem like anyone has had this problem before. Can someone at least explain the difference between the CGI and the ASAPI options?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.