Jump to content


Photo

mail() function won't send out any mail


  • Please log in to reply
3 replies to this topic

#1 jrodd32

jrodd32
  • Members
  • PipPipPip
  • Advanced Member
  • 41 posts

Posted 18 October 2006 - 12:22 PM

I am not recieving any errors yet I am also not recieving any email.  I checked the php.ini file and my sendmail binary is in the right spot so I am lost...

<?php
while($row = mysql_fetch_assoc($officialslist))
  {
   if(($ID==$row[id])&&($SSWEB==$row[SSWEB]))
   {
    if(($sport == 'BA')||($sport == 'FB')||($sport == 'TR')||($sport == 'WR'))
      {
        $to='user1@webmail.khsaa.org,user2@webmail.khsaa.org,user3@webmail.khsaa.org';
        foreach($source as $concern)
          $subject=$concern;
        $message="<br>
	$explaination
        <br>
        $row[id];
        <br>
        $row[lname].$row[suffix].', '.$row[fname];
        <br>
        $row[homephone];
        <br>
        $row[workphone];
        <br>
        $row[email]";
        $headers='X-Mailer: PHP/' .phpversion();
        mail($to, $subject, $message, $headers);
      }
?>


#2 xsist10

xsist10
  • Members
  • PipPipPip
  • Advanced Member
  • 114 posts

Posted 18 October 2006 - 12:26 PM

Need some information from you.

The server is Windows / Linux / ???

What mail command is php.ini pointing to (default is sendmail I believe) ?
SA PHP Archives - www.phparchives.za.org

#3 jrodd32

jrodd32
  • Members
  • PipPipPip
  • Advanced Member
  • 41 posts

Posted 18 October 2006 - 12:27 PM

Linux server...and it does point to sendmail

#4 jrodd32

jrodd32
  • Members
  • PipPipPip
  • Advanced Member
  • 41 posts

Posted 18 October 2006 - 04:13 PM

Can anybody come up with anything?




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users