Jump to content

Archived

This topic is now archived and is closed to further replies.

richard smooth

how to change php.ini PATH

Recommended Posts

Need help with php error!

I have installed ZCS Open Source Edition (on suse linux) with success but received php error trying to install oscommerce catalog and phpmyadmin :
PHP Warning: Unknown(): Unable to load dynamic library '/usr/lib/php/extensions/mysql.so' - libmysqlclient.so.15: cannot open shared object file: No such file or directory in Unknown on line 0.
PHP Warning: Unknown(): Invalid library (maybe not a PHP library) 'libmysqlclient.so' in Unknown on line 0

I have tried possible solutions like copying both files to my extentions dir and uncommenting the directives in php.ini but no success so far. I have read somewhere that I might have to recompile php but I have no idea how this will affect my zimbra and it's already running services.

My phpinfo() is pointing to /opt/zimbra/php-5.0.5/lib/php.ini for my php.ini PATH while my php.ini was actually in /etc/php.ini. I have tried copying php.ini to /opt/zimbra/php-5.0.5/lib/ as indicated by phpinfo() but it doest work.

How do I change the env path for php to read /etc/php.in as this is where my php.ini is located?
What do I need to do to sort this out guys? Please help!  Thanks.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.