Jump to content

Archived

This topic is now archived and is closed to further replies.

Fearpig

SMTP error (**SOLVED**)

Recommended Posts

Hi Guys,
My form to e-mail script is giving me the following error:

[code]Warning: mail() [function.mail]: Failed to connect to mailserver at "fer-mail" port 25, verify your "SMTP" and "smtp_port" setting in php.ini or use ini_set() in D:\Intranet v3\Process_Request_Form2.php on line 25

Can't send email[/code]

How do I go about confirming that the details are correct? I'm using PHP 5, IIS, Exchange, Windows Server 2003.

Any help would be appreciated.  :)

Share this post


Link to post
Share on other sites
Right then -

I've had a look at my 'Default SMTP Virtual Server' on exchange on my e-mail server and...

- TCP port is set to 25
- the Relay open to all
- connections are allowed by all
- anonymous, basic authentication and integrated windows authentication are all allowed

I've had a look on IIS on the webserver and...

- under 'Default SMTP Virtual Server' all the settings match the exchange server
- under the domain name 'Allow incoming mail...' has been ticked

I've had a look at the PHP.ini file and have the following details for the mail function...

[code][mail function]
; For Win32 only.
SMTP = 200.10.10.20; for Win32 only
smtp_port = 25
;sendmail_from= me@localhost.com ; for Win32 only

; For Win32 only.
sendmail_from = me@mydomain.co.uk

; For Unix only.  You may supply arguments as well (default: "sendmail -t -i").
;sendmail_path =

; Force the addition of the specified parameters to be passed as extra parameters
; to the sendmail binary. These parameters will always replace the value of
; the 5th parameter to mail(), even in safe mode.
;mail.force_extra_parameters =[/code]




Can anyone see where I am going wrong? As far as I can see this should all now be working.

[i]Please Help!!!![/i]  :-\

Share this post


Link to post
Share on other sites
::) Incase anyone else has this problem.... take a deep breath, look at it again.

Ohhh..... its being blocked by the Antivirus on the Web Server!
:P

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.