Jump to content


Photo

extension_dir not setting


  • Please log in to reply
8 replies to this topic

#1 djoshi

djoshi
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 14 September 2005 - 01:14 PM

Hi all,

I am a newbie. I have installed PHP 5.0.4 on my Win2k server with IIS. The test page is working fine. The phpinfo() also works ok.

However, I need to work with Oracle10g as the backend for my PHP apps. I tried to set the extension_dir directive in the php.ini file to ".\ext\" and also removed the semicolons on the two oracle related extensions viz. php_oci8.dll and php_oracle.dll.

After setting these things, when I restart the IIS and execute the phpinfo() page, I receive the following warning message box:

---------------------------
Warning
---------------------------
PHP Startup: Unable to load dynamic library '.\ext\php_oci8.dll' - The specified procedure could not be found.
---------------------------
OK
---------------------------

For your reference, I am including the various phpinfo() details here:
Configuration File (php.ini) Path => F:\PHP504\php.ini
extension_dir => .\ext\
Path => F:\PHP504;D:\WINNT\system32;D:\WINNT;
SERVER_SOFTWARE => Microsoft-IIS/5.0
SystemRoot => D:\WINNT
SCRIPT_FILENAME => d:\inetpub\wwwroot\TestSite\tut_phpinfo.php
Server API => CGI/FastCGI
PHP API => 20031224
PHP Extension => 20041030
Zend Extension => 220040412

Also, in the Windows registry, I have set the following:
[HKEY_LOCAL_MACHINE\SOFTWARE\PHP]:IniFilePath=F:\PHP504

Under this F:\PHP504 (which is the root PHP folder), I have the following folders:
.\dev
.\ext
.\ErrorLogs (I created this to receive error logs)
.\extras (this has three more folders underneath)
.\Manual
.\PEAR (this has one more folder underneath)

I hope the above information is sufficient.

Can someone please help me resolve this issue? I believe that until this is done, I will not be able to connect to the backend Oracle Database from my PHP scripts.

Thanks for your time and advice.

Regards.

#2 sikofitt

sikofitt
  • New Members
  • Pip
  • Newbie
  • 6 posts

Posted 27 September 2005 - 02:08 PM

try adding the drive to \ext\

#3 neylitalo

neylitalo
  • Staff Alumni
  • Advanced Member
  • 1,854 posts
  • LocationMichigan, USA

Posted 27 September 2005 - 07:03 PM

you need to use absolute paths. (I think that's what sikofitt's trying to say)

ie: c:\php\ext
http://nealylitalo.net - My personal website, and home of The Netizen's Journal.

#4 djoshi

djoshi
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 28 September 2005 - 03:47 AM

Hello again!

Thanks for your reply. I have tried setting the

extension_dir = "F:\PHP504\ext\"

but it has not made any difference. The error continues in the same way. Please suggest a different remedy if one exists.

Thanks again, and regards,
DJoshi

#5 tkv

tkv
  • New Members
  • Pip
  • Newbie
  • 2 posts

Posted 28 September 2005 - 04:07 PM

You have 2 options for it:
1. disable it
open php.ini search php_oci8.dll put ; in the begging line
2. enable it
search on the web the driver of it (oci8.dll) copy into
%root%/system32 (of windows)
you also have create the folder ext in the php directory within php_oci8.dll file

good luck

#6 permutations

permutations
  • New Members
  • Pip
  • Newbie
  • 3 posts

Posted 19 October 2005 - 01:48 PM

Hello again!

Thanks for your reply. I have tried setting the

extension_dir = "F:\PHP504\ext\"

but it has not made any difference. The error continues in the same way. Please suggest a different remedy if one exists.

Thanks again, and regards,
DJoshi

View Post


Did you find the solution to this? It's driving me crazy, too.


#7 turbosport

turbosport
  • Members
  • Pip
  • Newbie
  • 9 posts

Posted 14 January 2006 - 02:45 AM

[!--quoteo(post=308213:date=Oct 19 2005, 01:48 PM:name=permutations)--][div class=\'quotetop\']QUOTE(permutations @ Oct 19 2005, 01:48 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
Did you find the solution to this? It's driving me crazy, too.
[/quote]


Make sure the IUSR_machinename account has read and execute rights to the folders and files

#8 purplegecko

purplegecko
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 15 February 2006 - 09:19 AM

I had this problem and it was annoying me for ages!!

I found that the msvcr71.dll was missing.

This is the Microsoft C++ Rutime libraries, which should be distributed with any package that needs them. It is not installed by Windows.

You shouldn't put this file into the system directory (apparently) so just drop it into your PHP folder and all will be good!

#9 snuzzolillo

snuzzolillo
  • New Members
  • Pip
  • Newbie
  • 1 posts

Posted 04 September 2006 - 09:55 PM

purplegecko:

Your reply is very, very important. I had the same problem in one server of two, and comparing one whith other aparrently all was ok. except that detail.

Your reply was very helpful....





0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users