Jump to content

Archived

This topic is now archived and is closed to further replies.

chapman

stuck trying to get ssl working

Recommended Posts

Hello all,
I'm having extensive trouble trying to get ssl working again.
I recently upgraded apache from 2.0.5x to 2.2.3. However, ssl was working fine for a couple weeks after this. Then basically out of the blue it stopped working.
I am also running PHP 5.1.6 and  have openssl-devel-0.9.7a-43.14 and openssl-0.9.7a-43.14 installed on a RHEL 4 machine with all of the updates on it.
I haven't changed anything in any of the apache config files (namely httpd.conf and ssl.conf)

when i try to access my site via https://website.com it just gives me a cannot find server - page cannot be displayed" error. I have tried recompiling apache and php with no luck. my config commands look like this:

PHP
[code]./configure --prefix=/usr/local --host=i686-pc-linux-gnu --with-apxs2=/usr/local/apache/bin/apxs --mandir=/usr/share/man --infodir=/usr/share/info --datadir=/usr/share --sysconfdir=/etc --localstatedir=/var/lib --with-libxml-dir=/usr/local/lib --libdir=/usr/lib --with-config-file-path=/etc --with-pear --enable-bcmath --without-bz2 --enable-calendar --without-cpdflib --disable-ctype --with-curl --without-curlwrappers --enable-dbase --disable-dio --enable-exif --without-fam --without-fbsql --without-fdftk --disable-filepro --enable-ftp --with-gettext --without-gmp --without-hwapi --without-iconv --without-informix --without-ingres --without-interbase --without-kerberos --enable-mbstring --without-mcve --disable-memory-limit --with-mhash --without-mime-magic --without-ming --without-mnogosearch --without-msql --without-mssql --with-ncurses --without-oci8 --without-oracle --with-openssl --with-openssl-dir=/usr/bin --without-ovrimos --enable-pcntl --without-pfpro --without-pgsql --disable-posix --with-pspell --without-recode --disable-shmop --without-snmp --enable-soap --enable-sockets --disable-spl --without-sybase --without-sybase-ct --disable-sysvmsg --disable-sysvsem --disable-sysvshm --with-tidy --disable-tokenizer --enable-wddx --with-xsl --with-xmlrpc --disable-yp --with-zlib --enable-debug --without-cdb --with-db4 --without-dbm --without-flatfile --with-gdbm --without-inifile --without-qdbm --with-jpeg-dir=/usr/lib --with-freetype-dir=/usr/lib --with-t1lib=/usr/lib --with-ttf=/usr/lib --enable-gd-jis-conf --enable-gd-native-ttf --with-png-dir=/usr/lib --with-tiff-dir=/usr/lib --without-xpm-dir --with-gd --with-unixODBC=/usr/ --without-adabas --without-birdstep --without-dbmaker --without-empress --without-esoob --without-ibm-db2 --without-iodbc --without-sapdb --without-solid --with-mysql --with-mysql-sock=/var/lib/mysql/mysql.sock --without-mm --without-msession --without-sqlite --enable-dba --with-readline --without-libedit --enable-xslt --with-xslt-sablot --without-tidy --with-mcrypt --with-ldap
[/code]

APACHE
[quote]./configure --prefix=/usr/local/apache --enable-so --enable-ssl --enable-rewrite[/quote]

now how i understand it in apache 2.2.x you don't need the usual "startssl" flag when starting apache.

starting, stopping, restarting apache yields no errors and starts the regular http fine
does anyone have any ideas as to how i can debug this? I've tried recompiling with no luck and have no idea where to look for bugs/errors.

are there any known issues with my current setup?

any help would be greatly appreciated.
thanks
-Joe

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.