Jump to content

Function not found


Recommended Posts

Fatal error: Call to undefined function curl_init() in C:\(etc etc...)


Now I know the usual causes for a problem like this, but they are not solving anything.


Yes, extension=php_curl.dll is uncommented in the php.ini file.

Yes, phpinfo() displays the php.ini file I have been editing as the Loaded Configuration File.

Yes, extension_dir is set correctly in my php.ini file (other extensions work).

Yes, php_curl.dll exists in my ext/ folder.

No, phpinfo() does not display anything about cURL, anywhere :(


Where else can I look to possibly fix this?

Link to comment
Share on other sites

I have restarted the server several times, and my computer aswell.


Under phpinfo():

Configuration File (php.ini) Path C:\Windows

Loaded Configuration File C:\PHP\php.ini


So it would appear yes, this is the config file; unless there it is displayed somewhere else, but disabling other extensions such as mysqli in the file I am using effects the server. Is it possible the .dll file for curl is broken?



After some further research into the cURL dll file, I found out it uses two other dll files (libeay32 and sslea32), and it was suggested that they be copied into the C:\Windows folder.


After doing this, all cURL functions are running, and cURL is appearing in my phpinfo()

Link to comment
Share on other sites

This thread is more than a year old. Please don't revive it unless you have something important to add.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.