Jump to content

Archived

This topic is now archived and is closed to further replies.

wdo_will

Apache HTTP_HOST problem

Recommended Posts

I am having the weirdest problem that I can't seem to figure out.  Basically, my web host thinks it is always serving up requests to post 81, not 80, although I am always accessing it via port 80, of course.  Whenever I install a script (e.g. WordPress), it also thinks it is installing to port 81.  I tried doing a phpinfo(); and in the Apache HTTP_HOST section it says port 80, also.  This wouldn't be a problem, because I just go into WordPress's database with phpMyAdmin and change it, but it is messing up redirects via mod_rewrite and .htaccess for WordPress.  I set it up to use the nicer URIs in WordPress, and it writes to .htaccess, but just redirects to my homepage every time I try it out.  Has anyone every had this problem before, and if so, is it possible to fix via .htaccess (I don't have access to http.conf or php.ini)?

Share this post


Link to post
Share on other sites
You can always specify the port by simply adding it onto the end of a url e.g. www.myaddress.com:80

Sounds like to resolve the problem propaly however you will need access to the .cong or .ini (most likly a typo!).

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.