Jump to content

Archived

This topic is now archived and is closed to further replies.

TheNavigator

Phpmailer, Smtp -> Error: Ehlo Not Accepted From Server:

Recommended Posts

SMTP -> ERROR: EHLO not accepted from server:

SMTP -> ERROR: HELO not accepted from server:

SMTP -> ERROR: AUTH not accepted from server:

 

SMTP -> NOTICE: EOF caught while checking if connectedSMTP Connect() failed.

 

Thanfully, this time I've got an experienced person from namecheap to support me. We've tried to do everything we could, still doesn't work :(

 

function smtpmailer($to, $body) {
global $error;
$mail = new PHPMailer();  // create a new object
$mail->IsSMTP(); // enable SMTP
$mail->SMTPDebug = 1;  // debugging: 1 = errors and messages, 2 = messages only
$mail->SMTPAuth = true;  // authentication enabled
$mail->SMTPSecure = 'SSL'; // secure transfer enabled REQUIRED for GMail
$mail->Host = 'smtp.gmail.com';
$mail->Port = 465;
$mail->Username = 'no-reply@unlicrea.com'; 
$mail->Password = '******';		  
$mail->SetFrom('no-reply@unlicrea.com', UnliCrea);
$mail->Subject = 'Welcome to UnliCrea';
$mail->Body = $body;
$mail->AddAddress($to);
if(!$mail->Send()) {
 $error = 'Mail error: '.$mail->ErrorInfo;
 error_log($error);
 return false;
} else {
 $error = 'Message sent!';
 return true;
}
}

 

I hope someone can help. Thanks.

Share this post


Link to post
Share on other sites

In class.smtp.php search for the function Hello

Replace:
 SendHello("EHLO", $host))

with
SendHello("EHLO", "[" . $host . "]"))

Replace:
SendHello("HELO", $host)) 

with
SendHello("HELO", "[" . $host . "]"))

Share this post


Link to post
Share on other sites

It's solved, but that wasn't the problem.

 

The problem was actually

$mail->Host = 'smtp.gmail.com';

 

it shall be

$mail->Host = 'ssl://smtp.gmail.com';

 

Thanks for your support, though :)

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.