Jump to content

Oracle Not Loading With Php5 Under Iis7


Recommended Posts

I have been using PHP5 under IIS on a Windows 2003 Server and everything was fine.

I could use both Oracle and MySQL with PHP.


Recently, I upgraded another server to Windows 2008 R2.


I then followed some instructions on how to install PHP5 under IIS 7 from this web site:

http://www.howtogeek... ... rver-2008/


PHP now works fine including connecting to MySQL BUT

it refuses to work with Oracle (I am using Oracle 10g 64 Bit).


In php.ini I made sure that extension=php_oci8.dll was not commented out and restarted IIS

==> PHP still does not know about Oracle, the OCI8 is not even metioned in phpinfo !!!

I made sure that php_oci8.dll file is in the correct extensions folder, together with all other DLLs!


I tried to comment out the extension=php_mysql.dll to see whether the change would make any effect and whether I modified the correct php.ini file.

==> MySQL does not work when commencting out the php_mysql.dll line.

==> This means that I am modifying the correct php.ini file


So, I am stuck but I need php to know about my Oracle!


Please help


Here is some extra info from phpinfo.php


Compiler: MSVC9 (Visual C++ 2008)

Architecture: x86

Configure Command:

cscript /nologo configure.js "--enable-snapshot-build" "--enable-debug-pack" "--disable-zts" "--disable-isapi" "--disable-nsapi" "--without-mssql" "--without-pdo-mssql" "--without-pi3web" "--with-pdo-oci=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8=C:\php-sdk\oracle\instantclient10\sdk,shared" "--with-oci8-11g=C:\php-sdk\oracle\instantclient11\sdk,shared" "--with-enchant=shared" "--enable-object-out-dir=../obj/" "--enable-com-dotnet=shared" "--with-mcrypt=static" "--disable-static-analyze" "--with-pgo"


Server API: CGI/FastCGI

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.