Jump to content

Archived

This topic is now archived and is closed to further replies.

RobertP

Gludoe CMS

Recommended Posts

Well, this is my second time posting my project here. There have been way to many upgrades / re-factors to list. Basically it is a full functioning cms, with many features (that don't hinder the site's usability).

 

I would like to ask for the community to take a look, and try to break the site. If you find anything that looks odd / weird; please post as well.

 

 

Site: http://auth.gludoe.com/

Verification: http://auth.gludoe.com/phpfreaks.txt

 

Test Account:

Email: test1@gludoe.com

Password: test

 

 

PS: this is a link to my previous topic, in which i can not edit, so i decided to create a new one.

 

PPS: If the site is offline; it is running off my laptop at home, and sometimes it gets unplugged accidentally. I will do my best to keep it online until my testing purposes are completed.

Share this post


Link to post
Share on other sites

I broke it by disabling JS. Ended up going in an eternal loop, with it just showing the placeholders for the content.

Share this post


Link to post
Share on other sites

I severely dislike the page not extending to at least my screen height when the content fills up the pre-defined area.

Share this post


Link to post
Share on other sites
I broke it by disabling JS. Ended up going in an eternal loop, with it just showing the placeholders for the content.

 

What browser are you using, as with the browsers i have tested, (chrome,firefox,opera & safari) i do not have this issue.

 

 

 

 

I severely dislike the page not extending to at least my screen height when the content fills up the pre-defined area.

 

I am going to request a screenshot, as i am not sure as to where this could be; and if it is an annoyance, then it should be resolved.

Share this post


Link to post
Share on other sites

Version 12.00 
Build 1467 
Platform Linux 
System x86_64, 3.2.0-35-generic 

Browser identification
Opera/9.80 (X11; Linux x86_64; U; en-GB) Presto/2.10.289 Version/12.00

 

After disabling JS, and refreshing the page, I was able to confirm it on my desktop as well as my laptop.

 

This is the HTML code I got, and nothing changed across the multiple refreshes:

<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml" xml:lang="en" lang="en" dir="ltr">
<head>
	<meta http-equiv="Content-Type" content="text/html; charset=utf-8" /><noscript><meta http-equiv="refresh" content="0;URL='/plugin/Ajax/nojs/'" /></noscript>
	<meta name="description" content="Gludoe Development" />
	<meta name="keywords" content="gludoe, development, demo, cms" />
	<title>{pageTitle}</title>
	<link rel="stylesheet" type="text/css" href="/commons/styles/absolute/import.php?type=css" />
	<script type="text/javascript">
		var SITE_URL = "";
		var STYLE_URL = "/commons/styles/absolute";
		var CURRENT_SLUG = "plugin";
	</script>
	<script type="text/javascript" src="/commons/styles/absolute/import.php?type=js"></script>
</head>
<body>
	<div id="wrapper">
		<div id="menu">
			<table>
				<tr>
					<td><a href="/" id="logo"></a></td>
					<td><ul><li><a href="/register/">Register</a></li><li><a href="/login/">Login</a></li><li><a href="/forums/">Forums</a></li><li><a href="/">Home</a></li></ul></td>
				</tr>
			</table>
		</div>
		<div id="notice"></div>
		<div id="content">{pageContent}</div>
		<div id="credits">Page created in 0.016 seconds with 1 queries.<br />Powered by <a href="https://www.gludoe.com/" target="_blank">Gludoe CMS®</a> Version 1.0.2 Beta 1<br />Copyright © 2011 Gludoe Enterprises. All rights reserved.</div>
	</div>
</body>
</html>

 

It's the following line which causes the endless loop:

<noscript><meta http-equiv="refresh" content="0;URL='/plugin/Ajax/nojs/'" /></noscript>

You seem to be missing some of the code that should handle these cases, which causes it to be echoed out at every pageload. This might be related to having cookies disabled as well.

Share this post


Link to post
Share on other sites
This might be related to having cookies disabled as well.

 

This is a circumstance that i did not test, so thank you for this. If you have cookies disabled, then you receive a new session upon each visit, so i will create a solution to this. (cached hash of user agent + ip; or similar)

 

http://i49.tinypic.com/kedvrt.png

 

Note the navigation and the vertical scroll bar.

 

I have been using a 15.6" laptop for most of my development, so i will have to definably load this on my 55" for further testing!

 

Once again, thank you to you both!

Share this post


Link to post
Share on other sites

I'm using a 1920x1080 resolution on a 22` monitor.

Share this post


Link to post
Share on other sites

I have increased the wrapper size for the whole site, and increased the admin panel layout as well, although i am having an issue with height %'s on tables; but that is my fault for using them in the first place. When i get home i will re-factor the admin panel dashboard.

 

As always, thank you to everyone that has taken a few minutes to give the site a test!

Share this post


Link to post
Share on other sites

Either you made it worse, or it renders a lot worse on Linux.

 

http://i.imgur.com/osHCL.jpg

 

EDIT: I was on Windows 7 in my other post.

 

I was able to replicate this error, so i will now be able to fix.

 

Once again, thank you everyone!

 

 

EDIT: Please give it a try now, tell me if it is still not expanding correctly.

Share this post


Link to post
Share on other sites

The issue from my last screenshot is fixed. However, the nav menu still has a scrollbar when you expand the menus. This looks like a design decision and not a bug, but personally I would still prefer that it expanded the whole page and used a normal page scroll.

 

However, that's just my opinion and preferance. It looks like the bug has been fixed.

Share this post


Link to post
Share on other sites

Keep in mind that the 'styles' for this cms, are all independent, meaning that they can be changed very easily. Since i am not a designer, this is what i have created, and i am pleased with.

Share this post


Link to post
Share on other sites
This might be related to having cookies disabled as well.

 

If you could test my fix for this, would be grateful!

Share this post


Link to post
Share on other sites

This time I was redirected to the following address, which just gave me a blank page:

http://auth.gludoe.com/plugin/Ajax/

 

I think you might need to go back to the drawing board with this particular piece of functionality, and decouple the AJAX from the core a bit.

Share this post


Link to post
Share on other sites

Login does not work :(

 

I am testing a new core, so the test account has not been added yet, lol sorry about that

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.