Jump to content

Recommended Posts

When i run the following code,it will shows the error...

Mail error: The following From address failed: uppalakishore@hotmail.com : Called Mail() without being connected

//	require_once("./Includes/PHPMailer/class.smtp.php");
define('GUSER', 'myname@gmail.com'); // GMail username
define('GPWD', 'mypassword'); // GMail password
function smtpmailer($to, $from, $from_name, $subject, $body) { 
	global $error;
	$mail = new PHPMailer();  // create a new object
	$mail->IsSMTP(); // enable SMTP
	$mail->SMTPDebug = 0;  // debugging: 1 = errors and messages, 2 = messages only
	$mail->SMTPAuth = true;  // authentication enabled
	$mail->SMTPSecure = 'ssl'; // secure transfer enabled REQUIRED for GMail
	$mail->Host = 'smtp.gmail.com';
	$mail->Port = 465; 
	$mail->Username = GUSER;  
	$mail->Password = GPWD;           
	$mail->SetFrom($from, $from_name);
	$mail->Subject = $subject;
	$mail->Body = $body;
	if(!$mail->Send()) {
		$error = 'Mail error: '.$mail->ErrorInfo; 
		return false;
	} else {
		$error = 'Message sent!';
		return true;
if (smtpmailer('myname@gmail.com', 'uppalakishore@hotmail.com', 'PHotoGallery', 'test mail message', 'Hello World!')) {
	// do something
if (!empty($error)) echo $error;


Thanks in Advance For Watching...

Link to comment
Share on other sites

  • 3 weeks later...

Thanks For ur Reply @

Christian F...

I Solved it...as follows:


$mail=new PHPMailer();

$mail->IsSMTP();                   //Important b'coz by this stmt we sent mail using smtp
$mail->SMTPAuth = true;       // enable SMTP authentication
$mail->SMTPSecure = "ssl";  // sets the prefix to the servier
$mail->Host = "smtp.gmail.com"; // sets GMAIL as the SMTP server
$mail->Port = 465; // set the SMTP port for the GMAIL server
$mail->Username = "yourmail@gmail.com"; // GMAIL username
$mail->Password = "your mail password"; // GMAIL password

$mail->FromName = "PhotoGallery:Admin";
$mail->From = "from address@gmail.com";
$mail->Subject = $subject;

$mail->Body ="body of the message";
    return $result;






Link to comment
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.