Jump to content

Windows Authentication not being impersonated - Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON'


Recommended Posts

PHP v5.2.17

IIS v7.5

 

I have a script that hits a MS SQL db that is authenticated via Windows. If I run the script on the local server (localhost for example), it recognizes my Windows logon and passes the logon to MS SQL Server and all is well.

 

However, when I run the page from another PC, the script fails with: "Login failed for user 'NT AUTHORITY\ANONYMOUS LOGON' ".

 

I have the page Authentication set so Anonymous Authentication is Disabled, and Windows Authentication is Enabled. This is the correct setting. I know. So why is it that the server isn't authenticating me via the web and passing along the authentication "impersonating" me for MS SQL?

 

 

I've tried setting fastcgi.impersonate to 0, but that doesn't help at all. Here's my PHP.INI settings:

default_socket_timeout = 60
upload_tmp_dir="C:\Windows\Temp"
session.save_path="C:\Windows\Temp"
error_log="C:\Windows\temp\php-errors.log"
cgi.force_redirect=0
fastcgi.impersonate=1
fastcgi.logging=0
cgi.fix_pathinfo = 1

Any tips, help appreciated!

Link to comment
Share on other sites

This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.