Jump to content

Archived

This topic is now archived and is closed to further replies.

244863

Cakephp ACL

Recommended Posts

I have installed the AclExtras Plugin

 

and within the plugin have the following:

 

public $dataSource = 'default';

 

my default datasource is:

 

public $default = array(
        'datasource' => 'Database/Sqlserver',
        'persistent' => false,
        'host' => 'IAINROSE\SQLEXPRESS',
        'login' => 'administrator',
        'password' => 'd3veloper',
        'database' => 'clearview',
        'prefix' => '',
    );

 

The rest of the app can connect and functions as normal, but when I try and run the plugin commands e.g.

 

cake -app "c:\wamp\www\app" AclExtras.AclExtras aco_sync

 

I get the following error:

 

database connect Sqlserver is missing, or could not be created??

 

Any ideas why only the plugin can not connect??

Share this post


Link to post
Share on other sites

Does XAMPP have a proper connection to MSSQL?  

Share this post


Link to post
Share on other sites

Yes, my whole site works fine. It is just the plugin that does not like it. I have a feeling it is to do with the default database connection using a Datasource of Database/Sqlserver and the plugin not liking / finding the file location. But I'm not sure how to test / change it too????

Share this post


Link to post
Share on other sites

Try to change (just for a test) database driver from 'datasource' => 'Database/Sqlserver' to 'datasource' => 'Database/Mysql'.

Share this post


Link to post
Share on other sites

It says the same thing: Database connection "Mysql" is missing????

Share this post


Link to post
Share on other sites

Hi,

 

The answer was because Apache was looking at a different PHP ini file, so could not connect through the command line.

 

Thanks,

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.