Jump to content

Archived

This topic is now archived and is closed to further replies.

Irate

IIS 7.5 Port Change

Recommended Posts

So, basically, I have configured IIS via Command Prompt and everything's working fine, now I have downloaded WAMPP and Apache throws me - rightfully - an error that it cannot be started because 'server' is already listening to Port 80.

 

How do I change the port IIS is listening to via Command Line? I want to experiment with both IIS and Apache, so I'm asking. Thanks in advance.

P.S.: A method to change the port Apache is listening to is also welcome.

Share this post


Link to post
Share on other sites

For apache you edit the httpd.conf file and change the Listen 80 line. Change 80 to be whatever new port you want, save, then restart apache.

 

I've no idea how you edit the IIS port via the command line, but if you use the administration GUI you'd just edit the bindings in the site configuration.

Share this post


Link to post
Share on other sites

Fair enough.

 

I can set the port Apache is listening to to 8080 without conflicting the 80 port of 'system', right?

Share this post


Link to post
Share on other sites

Hmmm...

 

I changed Listen 80 to Listen 127.0.0.1:8080 but when I try to start Apache from my XAMPP Control Panel, this is the warning I receive before even starting...

 

 

17:42:25  [main]  Initializing Control Panel
17:42:25  [main]  Windows Version: Windows 7 Home Premium SP1 64-bit
17:42:25  [main]  XAMPP Version: 1.8.1
17:42:25  [main]  Control Panel Version: 3.1.0 3.1.0 [ Compiled: September 20th 2012 ]
17:42:25  [main]  Running with Administrator rights - good!
17:42:25  [main]  XAMPP Installation Directory: "c:\php\xampp\"
17:42:26  [main]  Checking for prerequisites
17:42:26  [main]  All prerequisites found
17:42:26  [main]  Initializing Modules
17:42:26  [Apache]  Problem detected!
17:42:26  [Apache]  Port 80 in use by "system"!
17:42:26  [Apache]  Apache WILL NOT start without the configured ports free!
17:42:26  [Apache]  You need to uninstall/disable/reconfigure the blocking application
17:42:26  [Apache]  or reconfigure Apache to listen on a different port
17:42:26  [Apache]  Problem detected!
17:42:26  [Apache]  Port 443 in use by "c:\program files (x86)\skype\phone\skype.exe"!
17:42:26  [Apache]  Apache WILL NOT start without the configured ports free!
17:42:26  [Apache]  You need to uninstall/disable/reconfigure the blocking application
17:42:26  [Apache]  or reconfigure Apache to listen on a different port
17:42:26  [main]  Starting Check-Timer
17:42:26  [main]  Control Panel Ready
17:42:29  [Apache]  Attempting to start Apache app...
17:42:30  [Apache]  Status change detected: running
17:42:31  [Apache]  Status change detected: stopped
17:42:31  [Apache]  Error: Apache shutdown unexpectedly.
17:42:31  [Apache]  This may be due to a blocked port, missing dependencies, 
17:42:31  [Apache]  improper privileges, a crash, or a shutdown by another method.
17:42:31  [Apache]  Check the "/xampp/apache/logs/error.log" file
17:42:31  [Apache]  and the Windows Event Viewer for more clues

Share this post


Link to post
Share on other sites

Bump, I guess.

 

Still getting the same error.

Share this post


Link to post
Share on other sites

It look like whatever you did to try and change the port was unsuccessful. Perhaps the wrong config file or the change was not save properly. You'll also need to either disable the SSL port (443) or change it to something else.

Share this post


Link to post
Share on other sites

I edited httpd.conf, I am sure about it.

 

So I cannot have Skype online while I am trying to boot Apache? :l

Share this post


Link to post
Share on other sites

Update: as I expected, I cannot boot Apache while Skype is online (means that this should have been in another section, but, oh well).

Solved and marked as such.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.