Jump to content

error http 500


Recommended Posts

New to CakePHP. Reading tutorials.

Need to get an old CakePHP 1.3.2 project to run. It was made by someone else.


Can look at a test site that is running and have a copy of the code that site uses in directories starting with app/. Also there is an index.php in the directory above app/.

Have data and am able to query it with a basic CakePHP program that isn't part of the project.


The url for the test site is like http://agroup.ab.aml/brd and when clicked on turns to http://agroup.ab.aml/brd/index.php/admin/user/add and gets an error "Internet Explorer cannot display the webpage."

If you backspace to http://agroup.ab.aml/brd/index.php/admin/user you get the same error.

If you backspace to http://agroup.ab.aml/brd/index.php/admin you get part of a CakePHP program with what looks like a custom error saying "requested address admin/ was not be found on this server."

If you backspace to http://agroup.ab.aml/brd/index.php, it automatically goes to http://agroup.ab.brd/index.php/users/login and get the whole 1st page of the CakePHP program.


Tried to get the code I was given to run but when I try the urls above, I get "The website cannot display the page http 500", even with a url that looks just like the one that works on the test site.


1. What causes the urls to automatically change ?

2. What can cause the error http 500 if the directories, programs, and urls match ?


Link to post
Share on other sites

Thank you for writing back.

app/tmp/logs has one file in it called empty and it is empty.

The test site seems to work ok with the url like http://agroup.ab.brd/index.php/users/login and the code I have is supposed to match what is working.


Found users_controller.php and a function login() in it.

In routes.php set Router::connect('/',array('controller'=>'users','action'=>'login'));.

Got same error.

Link to post
Share on other sites


Immitated the url and routing (default) of the project that gets the error 500 with a very simple program and it ran ok.

Just looked for logs in directories under windows\logfiles. Either had no access to directories or no recent files there. Will get a server person to help.

Thank you very much.

Link to post
Share on other sites


This topic is now archived and is closed to further replies.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.