Jump to content

How to resolve problem of session_start on Linux


Recommended Posts

I had built my website in php, earlier on Windows platform and amply used session_start function. Later I shifted to Linux hosting and realized that each session_start is displaying a warning that headers already sent etc. Now I searched google and came to know that this problem comes when BOM or any other char has been sent prior to session_start. But BOM is inevitable in my case as it is a multilingual website. Now i came to know that changing php5.ini and setting some option may help avoid the problem but since this is a shared hosting, i had to search for how to set my own php.ini, i found too, but unfortunately php.ini options are also not taking effect (this is checked by using phpinfo function). Can somebody please help rescue the situation? Thanks for reading this.

Link to comment
Share on other sites

Thanks for the replies. Problem is not that I am using WIndows system, in fact I was hosting and developing on the Windows previously and now both are on Linux. But I don't know why same php script now not working on Linux. I think some setting is required to make session_start work properly but I don't know what exactly it is. @PravinS, session_start is on the top already.

Link to comment
Share on other sites

This thread is more than a year old. Are you sure you have something important to add to it?

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.