Jump to content

Archived

This topic is now archived and is closed to further replies.

TheMuffinMan

PHP5 + zts + pthreads installation issue

Recommended Posts

I hope this is the right sub-forum for this!

 

I am trying to install pthreads on my Ubuntu 12.04 server that is running PHP Version 5.5.8-3+sury.org~precise+2.  To my knowledge this was just a standard installation via apt-get.

sudo pecl install pthreads

this produces the following error:

checking checking for ZTS... configure: error: pthreads requires ZTS, please re-compile PHP with ZTS enabled

 

I understand that this means PHP was not  compiled with the --enable-maintiner-zts ./config flag.

 

What I DON'T know how to do is recompile PHP with this flag and then overwrite my current PHP installation.

 

I have done some googling on the subject but the few guides I have found are extremely high level, old, or not very complete, and sadly I am still somewhat of a novice when it comes to Linux.

Share this post


Link to post
Share on other sites

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.