Jump to content

Archived

This topic is now archived and is closed to further replies.

sambib

.htaccess/.htpasswd help needed

Recommended Posts

I've created a .htaccess file:

 

AuthName "Realm Name"

AuthType Basic

AuthUserFile D:/Apache/private/.htpasswd (also used this without the drive letter D:)

Order allow,deny

Allow From All

<Files les_mis_test.php> (also tried protecting the whole directory and not the individual file)

require valid-user

</Files>

 

I've created the .htpasswd file and put it into the specified directory

 

 

and here is the entry in my httpd.conf file:

 

<Directory "D:/Apache/htdocs/name_of_site_root_directory">

 

 

Options Indexes FollowSymLinks

 

 

AllowOverride All (also trid with AuthConfig)

 

 

Order allow,deny

Allow from all

 

</Directory>

 

When I try to access that file (les_mis_test.php) I get the dialogue box for the user name and password but then all I get is a 'blank' page (no code) though with the correct URL in the address bar.

 

I've installed apache 2 on my C: with all conf files etc there (windows xp) and I've got the data (htdocs) on my D: drive if that helps anyone suss out my errors...

 

CAN ANYONE TELL ME WHY I'M GETTING A BLANK PAGE RATHER THAN THE PAGE VIEWING NORMALLY. IS THIS A CONFIG ERROR WITH THE HTTPD.CONF OR DOES IT INDICATE AN ERROR ELSEWHERE.......?

 

 

VERY FRUSTRATED WITH THIS AND SPENT A LOT OF TIME RESEARCHING THIS PROBLEM WITH NO LUCK YET..........!

Share this post


Link to post
Share on other sites

god I'm dumb.........

 

it wasn't a conifg problem at all, it was my bloody includes/functions that I need to sort out.

 

all fixed nothing to see here, move along folks......:)

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.