Jump to content

TOR socks proxy server


jazzman1

Recommended Posts

Guys, I recently came across this about using a tor socks proxy as a default proxy server in my local home network. So, to my centos-box, I've set the service up with a default soks-port 9050 and the local ip address of this machine is 10.10.1.5. Here's a part of the tor's config file:

 

 

SocksPort 10.10.1.5:9050

 

[jazz@centos-box ~]$ top -u jazz | grep tor                                                                                                                                     
 3413 jazz      20   0 76256  32m 9720 S  0.0  0.3   0:01.55 tor

[jazz@centos-box ~]$ nmap -Pn 10.10.1.5 | grep 9050

9050/tcp open  tor-socks

 

Now, I'm completely able to use that socks proxy from the centos-box with my default browser / curl or whatever you want to be, but if I go to my laptop and set the proxy-socket up to its browser, I've got a message of "TOR is not an HTTP proxy" and half or more ( not all of them ) of my bookmarks web-sites don't work. However, a message when I'm running this service says:

 

 

Sep 12 13:16:01.769 [notice] You configured a non-loopback address '10.10.1.5:9050' for SocksPort.

This allows everybody on your local network to use your machine as a proxy. Make sure this is what you wanted.
Sep 12 13:16:01.769 [notice] Opening Socks listener on 10.10.1.5:9050
 

 

Ideas?

Link to post
Share on other sites

Archived

This topic is now archived and is closed to further replies.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.