Jump to content


Photo

RedHat 9 Upgrade Causing Apache Error?


  • Please log in to reply
1 reply to this topic

#1 hexzero

hexzero
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 02 April 2003 - 09:06 PM

Okay, I updated to RH 9 today. Yeah Yeah, I know stupid thing to do so soon, but I am a newb to the ^nth degree here. Anyway, I am getting an error when trying to start my apache server after the upgrade:

Syntax error on line 239 of /usr/local/apache/conf/httpd.conf:
Cannot load /usr/local/apache/libexec/libphp4.so into server: /usr/local/apache/libexec/libphp4.so: symbol errno, version GLIBC_2.0 not defined in file libc.so.6 with link time reference
./apachectl startssl: httpd could not be started


Just wanted to see if anyone has seen this yet and what it means. If it is an easy fix, I appreciate the posts.

Thanks!

#2 effigy

effigy
  • Staff Alumni
  • Advanced Member
  • 3,600 posts
  • LocationIL

Posted 04 April 2003 - 04:21 AM

what do the php configuration lines look like in the httpd.conf? (no need to post the whole thing)

what version of php/apache?

what configure line did you use?

e.g.
./configure --with-apxs2=/usr/local/apache ...etc.
Regexp | Unicode Article | Letter Database
/\A(e)?((1)?ff(?:(?:ig)?y)?|f(?:ig)?)\z/




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users