Jump to content
Sign in to follow this  
Stefany93

[Laravel] Can't get the "laravel" command to run in the CMD

Recommended Posts

Hello,

I installed composer and then I tried installing the laravel command line functions as it was described in their website, namely I ran this command:


composer global require "laravel/installer=~1.1"

Taken from directly from the official website - http://laravel.com/docs/4.2#install-laravel

But when I run:

laravel new blog 

I get an error:


C:\xampp\htdocs>laravel new blog
'laravel' is not recognized as an internal or external command,
operable program or batch file.

Please help! I really want to use the "laravel" command lines from the CMD.

I am on Windows 8.1.

I searched a lot in Google for help but with no luck :( Many thanks!

Share this post


Link to post
Share on other sites

And you did this?

"Make sure to place the ~/.composer/vendor/bin directory in your PATH so the laravel executable is found when you run the laravel command in your terminal."

  • Like 1

Share this post


Link to post
Share on other sites

If you go directly to that directory look for the laravel.bat or similar an try to execute it there... The error message is clear enough... Did you try restarting your computer and try?

Edited by mikosiko
  • Like 1

Share this post


Link to post
Share on other sites

Thank you very much, but laravel.bat is not in this directory :( I restarted the pc without luck :( :(

Share this post


Link to post
Share on other sites

Fixed the problem. It turned out that the PATH was NOT included, I thought it was, but that path turned out to be the one of composer for its CMD commands, not the Laravel ones.

 

So I ran

composer global require "laravel/installer=~1.1"

and then the message appeared

" Changing directory to C:\Users\Stefany\AppData\Roaming\Composer\vendor\bin "

So I went to that directory and I saw that laravel.bat file WAS THERE, so I copied the path and pasted in in the system variavles windows, then ran the Laravel command:

laravel new blog

And it worked!

 

 

Many thanks for your help!

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.