Jump to content
fivestringsurf

V-Hosts on OSX Disappeared!

Recommended Posts

Ever have one of those problems that makes no sense?  Yep that's me for the past 2 days...

 

I've had apache/php stack set up on my osx machine for at least 6 years with little to no problems.

I had all of my v-hosts for local sites  under   /etc/apache2/other  (they were included via httpd.conf)

 

All of a sudden my local sites stopped working and after tracking down the problem by using:

>sudo apachectl -t

 

I found out that my v-hosts where no longer there... heck the whole directory /etc/apache2/other was missing.

 

Now I'm quite sure I did not touch this...the question remains... what the hell happened?

 

Now I'm not foolish enough to think someone is going to be able to tell me what happened precisely but some insight would be nice:

 

Has this happened to any of you before?  Did osx auto update something and wipe things out?   I mean ... I didn't update to a major release... still on El Capitan.

Was it an automatic xcode update?

 

I'm very baffled right now.

Edited by fivestringsurf

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.