Jump to content

windows to linux migration


Recommended Posts

Can someone assist me please.
I am trying to shift my mysql database from windows xp to centos 6.
On the windows I am running
mysql 5.0.83 and using administrator 1.2.17
However on the linux I am running
mysql 5.1.83 and trying to use workbench 6.3

I have backed up my database using the administrator
This created a windows Backup.sql file.

Trying to transfer this to linux and then restore it will not work.
The workbench just will not see the file even if I rename it.

My next trial was to open the backup file with Kwrite and then to copy
and paste the content directly into a mysql terminal.

This was successful on creating no only the database but all the tables.

However the data for the tables was a different story.

If there was a very limited number of rows of data it worked
Anything over 10 rows gives me a mysql syntax error.

Is there a way around this other than
trying to edit a file with thousands of rows of data.

I know there is a difference in the mysql proc table column numbers
from 16 in the older version to 20 in the newer but I
do not think that should make a difference here.
 

Link to post
Share on other sites

Thank you Kicken that worked just fine

Now I have another configuration problem I have to solve.

My firefox will not connect to the mysql.

Reading the error logs I find that it is trying to connect via /var/lib/mysql/mysql.sock and cannot find it

The correct location is of course /var/lib/mysqld/mysql.sock

There is obviously a configuration file somewhere that is using the wrong info, however I cannot find it.

/etc/my.cnf is correct as is /etc/php.ini

I checked the /etc/httpd content and that seemed OK too.

Obviously I am missing one somewhere but where??

Link to post
Share on other sites
This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.