Jump to content

Off topic but....


Go to solution Solved by ginerjm,

Recommended Posts

For the last few days you have been posting an "ad" (randomly) on the php forum (and probably others) that is very disruptive.  It is a plain black rectangular box that has a small red logo of some kind and an X in the corner which I can close the ad with.  But - randomly - it comes back.  There is no other identifier to help describe it to you.

 

The difficulty is that the ad seems to use JS code to keep bringing the focus back to your site.  If I leave the window to go look at another appl,  in a few seconds - like 3-4 - it forces me back to the Freaks page.  As I said - very disruptive.

 

You need to contact your ad provider and get them to remove this one from their pool.

 

Sorry to post here but I couldn't find another place to post this.

Link to post
Share on other sites

Not only does this phony ad re-claim focus when you are on another page, but it also ruins my attempts to make a post unless I go around the current page and x them off the page. What a PIA!

Link to post
Share on other sites
  • 4 weeks later...

Ok - this is happening regularly now over the last 2-3 days. It seems to be when the page doesn't show any ad at all in the reserved "ad space". All that is shown is a black box with a little red logo in the middle. At some regular interval (about 2 seconds!) it refreshes or something and grabs focus to the forum page in general. This then un-focuses me from the post I may have been typing in a reply to or it may even focus me onto the Freaks web page away from another website window I am looking at.

 

Whatever service you guys (phpFreaks.com) are using for generating ad revenue - you gotta fix it or get them to fix it.

 

And yes - I am using AdFender to block ads. It normally works pretty good but this provider manages to get thru it somehow.

 

PS - I notice there are none of these problems on this forum page I am posting on right now.

Link to post
Share on other sites

???

 

I am complaining about the new service I believe. This only began about 2 mos ago. When the 'space' has this black background and only a small red icon/logo/?? in the middle I am assuming that it is "no ad at all" and something is happening to interrupt my activities.

 

Are you saying that you never see this happening to you? Actually it hasn't happened to me in the last few hours but it did occur a couple times this am.

 

I'm reporting what I see as a problem. What do you want me to?

 

As for a screen print - do you have some method that I should use to create one for you? Not that one should really need a screen print of a black box with a little red thingie in the middle, but if you can't visualize that I can attempt to do the screenprint. Rarely have to do them so I never remember how.

Link to post
Share on other sites

Below is the code that I think generates the bogus ad that is the problem.

 

<tr>
<th scope='col' colspan='5'>
<script type="text/javascript">
google_ad_client = "ca-pub-8794381281316343";
google_ad_slot = "6221987221";
google_ad_width = 728;
google_ad_height = 90;
</script>
<!-- phpfreaks-topicView-728 -->
<script type="text/javascript"
src="//pagead2.googlesyndication.com/pagead/show_ads.js">
</script>
</th>
</tr>
This was copied from between the two forum posts shown in the image I previously provided.

 

My work here is done.

Link to post
Share on other sites

WTF version of IE are you using? I wouldn't be surprised if that's the problem.

 

That code is the generic Google Ads code that everybody uses. Did you do a View Source of the page? That will only show you what was returned by the server - the interesting part that I need to see is what ad code was injected into the page at that spot, and it happens with Javascript so View Source won't tell you what it is.

 

You need to do... well, I'm not sure what you can do with that IE. Modern versions have a developer tools thing (like every other browser has had for years) which let you inspect the DOM, and that is where you would see the dynamic HTML for the ad. It would appear immediately after that second

Link to post
Share on other sites

I am using 11.0.96

 

It is unadorned except for the adblock that was just added per suggestion.

 

I really don't care to be fixing it since I have no control over what is happening.

 

What is happening can't possibly be only happening to me. My thought is that nobody else notices it happening.

I just thought that the management of the forum might be interested that whomever they agreed to work with to earn some ad revenue was doing something very disruptive to their users. That doesn't seem to be the case since I am getting crapped on mostly for using a browser that I've been using forever and really have no reason to change.

 

Sure I'm in 2nd place as an IE user. I have tried chrome several times and just don't like it. Seems to run slower too which I definitely didn't like.

 

I have fed you what you have asked for. If you aren't seeing it in your environments, then I guess there is no reason for you to pursue any solution. What is amazing is that the "bogus ad" that shows up and causes this problem doesn't even seem to be an ad at all since clicking on it does absolutely nothing. All it does is attract focus when it is fed to my client periodically.

 

I feel like a newbie on the php forums coming here with my problem. Now I know how they feel.

Link to post
Share on other sites

Dude. Chill.

 

I'm honestly not sure what I can do at all, but I do know that I can't do anything unless I know what the problematic ad is. Sites on the internet don't hand-pick which ads they show: they use ad networks, and those networks delegate to other networks, and so on and so on until eventually it comes to the actual markup for an ad. PHP Freaks has little say in what ads are being shown. However, ad networks (the reputable ones) don't like to show disruptive ads because it bothers users and encourages them to switch to ad blockers and that's bad for business. Which is why it's even possible to report problematic ads in the first place - that hasn't always been available, you know.

 

Based on the logo and, well, distinct lack of advertising, I think that thing you're seeing is not so much an ad as it is some sort of placeholder for one. Perhaps there's a problem displaying the intended ad and that thing kicked in instead. That particular vendor often has a little arrow > thing in a corner to report a bad ad, however the thing in the top-right corner it doesn't quite look like what I'm thinking of. Could still be, though - try clicking it next time and see what happens. Worst case you get an ad and we get a tiny bit of revenue from your click. The X is also intriguing.

 

As for others seeing the same ad, I'm sure someone has. You say it takes focus? Most people browsing will load a page and then view it without interacting with elements on the page much until they click the next link, so if the thing was taking focus they might not even notice. And that's to say nothing about the mental filters that internet-dwelling people have developed that allows them to simply ignore ads. On the other hand, ads are becoming more and more tailored to individuals and their collection of tracking cookies, so maybe there aren't so many other people out there seeing it after all.

 

I want to help. Really. I don't know if I will be able to but I'm at least willing to try. But like I said, I can't do anything unless I know what the problematic ad (or whatever) is, and while a description and screenshot helps, what I really need is to know where the ad is coming from - and that means an IFRAME src... and hopefully that's enough.

Link to post
Share on other sites

Please don't tell me to 'chill'. Always hated that word. And if I was irate - well you've already seen me like that.

 

The x does in fact close the ad. And yes I thought I already mentioned that I thought this was a placeholder 'ad'. And it is noticeable if one has multiple browser windows open OR if one is trying to post (on the freaks forum) in one Reply box and it is currently on the page - stealing focus away from your typing before you can get 3 letters in a row typed out!

 

As for the other symbols I have clicked them and all they do is take me to google. From there I am at a loss. One thing that I notice is the 'ad' uses the word AdChoice but what google talks about is Adsearch and Adwords.

 

I would love to have you take an interest in this but I can't find anything more to give you. Couldn't find an reference to 'IFRAME' in the source and don't know what else to do for that . Tried to give you info that I did see but apparently you need more. Sorry. And you personally are never seeing this ad/ghost-ad on your browsers? It is quite obvious when it is there, no?

 

Be happy!

Link to post
Share on other sites

Clicking takes you to Google? That's bizarre. It's the kind of thing I would do, like "okay so we've got this placeholder and if the user clicks it they have to go somewhere, so... Google?"

 

AdChoice is the network I'm thinking of (but couldn't place the name so didn't mention it). They're the ones with the little > icons in the corners. Not sure what "Adsearch" is, but AdWords is a Google property so that's how you found it.

 

And for the IFRAME, like I said you won't find it in the source. You have to look at the HTML at runtime, which is only possible with a sort of HTML "inspector" thing in the browser (be that built-in or through an extension) since it's done by Javascript. That second

IE 11 has an inspector thing in its dev tools - hit F12, then you can use the "DOM Explorer" to browse through the page.

Link to post
Share on other sites

I'm not sure which of the URLs would be needed but this code seems like it should grab the first iframe's source:

document.getElementById('aswift_0').contentDocument.getElementById('google_ads_frame1').src;
You could try running that in the console or address bar using

javascript:console.log(document.getElementById('aswift_0').contentDocument.getElementById('google_ads_frame1').src);
Or open developer tools (F12), go to the DOM explorer and use the select element button to find the ad in the dom. Or right-click it and choose 'Inspect Element'. Edited by kicken
Link to post
Share on other sites
  • 2 weeks later...
  • Solution

Hooray!! It seems that this problem has been resolved. Today I saw the 'black box' ads once again but they are different. They not have a single little icon in the right corner and now say 'Adchoices' like most of the time ads show. And they don't grab focus from other open windows.

Link to post
Share on other sites
This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.