Jump to content


Photo

blank page?!?!?!?!


  • Please log in to reply
3 replies to this topic

#1 deadshot270

deadshot270
  • Members
  • Pip
  • Newbie
  • 1 posts
  • LocationAthens, AL

Posted 19 December 2005 - 02:54 PM

php: 5.0.3
web server: Apache 2.0.52
OS: Windows XP Pro SP1

ok i just got a new harddrive for my web stuff, i put it in and transferred all my websites to that drive, then i reinstalled php apche and mysql to that hard drive, i reconfigured apache2 and php, i serve several different domains off this server and now whenever i go to any script on any domain i host i get a blank page with no errors or anything, just a big white blank page, help me please

#2 ProFire

ProFire
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 20 December 2005 - 02:43 AM

[!--quoteo(post=328691:date=Dec 19 2005, 10:54 PM:name=deadshot270)--][div class=\'quotetop\']QUOTE(deadshot270 @ Dec 19 2005, 10:54 PM) View Post[/div][div class=\'quotemain\'][!--quotec--]
php: 5.0.3
web server: Apache 2.0.52
OS: Windows XP Pro SP1

ok i just got a new harddrive for my web stuff, i put it in and transferred all my websites to that drive, then i reinstalled php apche and mysql to that hard drive, i reconfigured apache2 and php, i serve several different domains off this server and now whenever i go to any script on any domain i host i get a blank page with no errors or anything, just a big white blank page, help me please
[/quote]

Did you check on the source of the script in your browser? If it's completely blank, then maybe you might want to reconfigure your apache again.

If there is like <html></html>, then maybe there is something wrong with the scripts. Could be your php OR apache.

#3 siezma

siezma
  • Members
  • Pip
  • Newbie
  • 8 posts

Posted 21 December 2005 - 11:26 PM

I have the same problem.I have checked this problem on the net.It is quite common.But i couln't find the reason.

If you have any solutions,please help

Bye

#4 Vorlin

Vorlin
  • Members
  • Pip
  • Newbie
  • 3 posts

Posted 29 December 2005 - 09:39 PM

Make sure that when configuring php, you have to use the '--with-apxs2=/location/of/apache 2/apxs' option.

My installation on linux went like this with PHP 5.1 and Apache 2.0.55:

1) unpacked both php and apache into their appropriate directories.
2) went into the apache directory and did the following configure:
# ./configure --enable-module=so --prefix=/var/www
<stuff here>
# make
# make install

3) backed out and went into my php directory and did the following configure:
# ./configure --with-pgsql=/db [color=red]--with-apxs2=/var/www/bin/apxs[/color] --with-png --with-gd --with-jpeg-dir=/usr
# make
<stuff here>
# make test
<stuff here>
# make install
<more stuff>
# cp php.ini-recommended /usr/local/lib/php.ini

The php configuration I did enabled png graphics with gd implementation, PostgreSQL support, and integration into Apache 2's config file (httpd.conf).

In your httpd.conf file, you need to make sure of a few things.

The lines below need to be put somewhere in the file (I put mine right after the Listen statement):
[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]
LoadModule php5_module modules/libphp5.so
AddType application/x-httpd-php .php
AddType application/x-httpd-php-source .phps
[/quote]

Modify the line of your DirectoryIndex to include php files. Mine's like this:
[!--quoteo--][div class=\'quotetop\']QUOTE[/div][div class=\'quotemain\'][!--quotec--]
DirectoryIndex index.php index.html
[/quote]

And that's it. Start up your webserver and test it out. On my command prompt, I do this:
# php -r 'echo phpinfo();'
<same info as you would see in a php test file appears here>







0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users