Jump to content
mstdmstdd

How to hide lacking phpmyadmin warnings?

Recommended Posts

On a remote ubuntu 18 server when opening data in phpmyadmin from one of the tables, it

displays the warnings and popup window(like that https://imgur.com/a/b5HGGV0), which is very lacking ...

Is there a way to ignore/hide them?

Server: Localhost via UNIX socket Server type: MySQL Server version: 5.7.23-0ubuntu0.18.04.1 - (Ubuntu) Protocol version: 10 User: root@localhost Server charset: UTF-8 Unicode (utf8)

Apache/2.4.29 (Ubuntu) Database client version: libmysql - mysqlnd 5.0.12-dev - 20150407 - $Id: 38fea24f2847fa7519001be390c98ae0acafe387 $ PHP extension: mysqliDocumentation curlDocumentation mbstringDocumentation PHP version: 7.2.10-0ubuntu0.18.04.1

phpMyAdmin Version information: 4.6.6deb5

Thank!

Share this post


Link to post
Share on other sites

Perhaps you should fix the underlying problem?

You've shown the backtrace. What is the error message?

Share this post


Link to post
Share on other sites

Sorry, Error wsa hidden. It was :

Warning in ./libraries/sql.lib.php#613
 count(): Parameter must be an array or an object that implements Countable

Share this post


Link to post
Share on other sites

Try updating: you're out of date by almost two years.

Share this post


Link to post
Share on other sites

That is ubuntu0.18.04.1 - thr lates which is on Digital Ocean. Do you think there is a way to update its phpMyAdmin ?

Share this post


Link to post
Share on other sites

I thought this problem sounded familiar. Look here. You can patch your install since that seems to be the only significant bug in 4.6.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.