Jump to content
NotionCommotion

Composer results in "continue" targeting switch is equivalent to "break" error

Recommended Posts

I am getting the following error when using composer: "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?

Just started.  I am pretty sure composer.json wasn't changed.  journalctl doesn't show anything.  Maybe Doctrine related, however, nothing seems to help.

Any ideas?
 

[michael@devserver www]$ php -v
PHP 7.3.4 (cli) (built: Apr  2 2019 13:48:50) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.3.4, Copyright (c) 1998-2018 Zend Technologies
    with DBG v9.1.9, (C) 2000,2018, by Dmitri Dmitrienko
[michael@devserver www]$ composer -V
Composer version 1.4.2 2017-05-17 08:17:52
[michael@devserver www]$ yum info composer
Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * base: mirror.us.oneandone.net
 * epel: mirror.rnet.missouri.edu
 * extras: mirror.us.oneandone.net
 * remi-php73: mirror.bebout.net
 * remi-safe: mirror.bebout.net
 * updates: mirror.us.oneandone.net
Installed Packages
Name        : composer
Arch        : noarch
Version     : 1.8.4
Release     : 1.el7
Size        : 1.8 M
Repo        : installed
From repo   : epel
Summary     : Dependency Manager for PHP
URL         : https://getcomposer.org/
License     : MIT
Description : Composer helps you declare, manage and install dependencies of PHP projects,
            : ensuring you have the right stack everywhere.
            :
            : Documentation: https://getcomposer.org/doc/

[michael@devserver www]$ composer update
Loading composer repositories with package information
Updating dependencies (including require-dev)


  [ErrorException]
  "continue" targeting switch is equivalent to "break". Did you mean to use "continue 2"?


update [--prefer-source] [--prefer-dist] [--dry-run] [--dev] [--no-dev] [--lock] [--no-custom-installers] [--no-autoloader] [--no-scripts] [--no-progress] [--no-suggest] [--with-dependencies] [-v|vv|vvv|--verbose] [-o|--optimize-autoloader] [-a|--classmap-authoritative] [--apcu-autoloader] [--ignore-platform-reqs] [--prefer-stable] [--prefer-lowest] [-i|--interactive] [--root-reqs] [--] [<packages>]...

[michael@devserver www]$

 

Share this post


Link to post
Share on other sites

That's a new warning for PHP 7.3.

Your composer is 1.4.2, current is 1.8.5.

Share this post


Link to post
Share on other sites

Thanks,  After trying to create a brand new project with no real packages, got the same error and figured it had to something like that.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.