Jump to content

changes in the UUID - how to achieve that !?

Recommended Posts


hello and good day,  dear community,


i need to change


UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults,noatime 0 2

to this 


  UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults 0 0



how to achieve that!?


look forward to hear from oyu

Link to post
Share on other sites

hello dear requinix many thanks for the quick reply

martin-pc martin]# cat /etc/fstab
# /etc/fstab: static file system information.
# Use 'blkid' to print the universally unique identifier for a device; this may
# be used with UUID= as a more robust way to name devices that works even if
# disks are added and removed. See fstab(5).
# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=A790-35CD                            /boot/efi      vfat    defaults,noatime 0 2
UUID=1bf0c824-0645-47da-b8a1-88eaaabecc33 /              ext4    defaults,noatime 0 1
UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap           swap    defaults,noatime 0 2
[martin-pc martin]# cat /etc/default/grub
GRUB_CMDLINE_LINUX_DEFAULT="quiet resume=UUID=ae33e597-0c72-4c66-9f16-6606322111c3"

# If you want to enable the save default function, uncomment the following
# line, and set GRUB_DEFAULT to saved.

# Preload both GPT and MBR modules so that they are not missed
GRUB_PRELOAD_MODULES="part_gpt part_msdos"

# Uncomment to enable booting from LUKS encrypted devices

# Uncomment to use basic console

# Uncomment to disable graphical terminal

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command 'videoinfo'

# Uncomment to allow the kernel use the same resolution used by grub

# Uncomment if you want GRUB to pass to the Linux kernel the old parameter
# format "root=/dev/xxx" instead of "root=/dev/disk/by-uuid/xxx"

# Uncomment to disable generation of recovery mode menu entries

# Uncomment and set to the desired menu colors.  Used by normal and wallpaper
# modes only.  Entries specified as foreground/background.

# Uncomment one of them for the gfx desired, a image background or a gfxtheme

# Uncomment to get a beep at GRUB start
#GRUB_INIT_TUNE="480 440 1"
[martin-pc martin]#

btw - i have had some issues  -. with the hibernate  due to a hung up upgrade  process (that was interrupted unfortunatly=)


well i guess that i need to do the corrections - and the change in the uuid .

look forward to hear from you





Link to post
Share on other sites

hello dear friends 
I think i have messed my fstab and probably the grub default:
From terminal:
cat /etc/fstab
cat /etc/default/grub

cf - see the very very good hints: 

i was recommended to to some things
For the root shell

Change this

UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults,noatime 0 2

UUID=ae33e597-0c72-4c66-9f16-6606322111c3 swap swap defaults 0 0

and remove ,noatime from the /boot/efi in your fstab ... All the rest seems ok ...

question: how to achieve that - how to do the necessary changes!? 

many thanks for any and all helping hand. 

Link to post
Share on other sites
This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.