Jump to content

Webmin: creation of a mysql-db with user, user permission - which is the correct sequence?


Recommended Posts

Using Webmin to Manage MySQL to manage the MySQL server installed on the Linux server. At the moment i have serious issues in installaing a web application installation - like Wordpress: i get back errors in establishing a db. 


i follow the sequence of steps: 
create user: 

create a MySQL database,

db-permission: for the given db: Once we have created a new MySQL database, we must now assign permissions to this database. Now that we have sucessfully created a new database, a new user, and set up a database permissions scheme for that database, our web application installation should be seamless. 

by the way; this guy here has a interesting setup: 

Virtualmin/webmin mysql user-database permissions 
https://www.youtube.com/watch?v=yDsKu3qNgdc

note: the sequence is very interesting

first he creates a new user ( to which he gives no permissons..) THAT is very very interesting... 

the permission are given in the step: "db-permission" - not (!!!) in the creation of users. 


what do you say!? 

Edited by dil_bert
Link to post
Share on other sites

 

hello dear all - found out more infos - 

 

i have seen a how-to: that guides through the process of setting up the db and the user: 


Create and Manage MySQL Users in Webmin
https://admin-ahead.com/forum/webminvirtualmin/create-and-manage-mysql-users-in-webmin/

Quote

 


To begin managing MySQL in webmin, do the following:

1) Login to webmin and find the section called “Servers”
2) Click “MySQL Database Server”
3) Select “User Permissions”

To create a new user:


1) Click “Create new user” under the table listing current users
2) Enter a user name and password
3) Select permissions (these are global privileges – you can set privileges for individual databases in another section
4) Click “Create”

To change permissions for specific databases, follow these steps:


1) From the MySQL Database Server page, click “Database Permissions”
2) Click the name of the database you want to manage
3) For “Username” toggle the box to the right of the anonymous box and enter the user you want to have permissions for this database
4) Select the permissions you want to grant. To select multiple permissions, hold the Control key and click them
5) Click “Save”.

 

 

Quote

 

 

well now i try to find out why it does not work with the installation of a wordpress-site..
note#: the wqeustion is: should i use

a. localhost or 
b. any host

love to hear from you

Edited by dil_bert
Link to post
Share on other sites
This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.