Jump to content
Sign in to follow this  

flashing MicroPython to ESP32 with ESP-Tool.py does not work

Recommended Posts

hello dear community, 

the issue: flashing MicroPython to ESP32 with ESP-Tool.py  does not work 


issue: unable to flash micropython to esp 32: open serial error, please try again. hope to connect internet and try again.
pretty new to micropython - want to flash micropython to esp 32 ( resp 8266) board.
cf this docs: https://maker.pro/esp8266/tutorial/using-micropython-on-an-esp8266-with-upycraft
getting this errors all the time.

open serial error, please try again.
hope to connect internet and try again.
current version only open py txt json ini file.
hope to connect internet and try again.
hope to connect internet and try again.

any idea;

update: - tried it with the so called esp-tool: 

took this tool - here https://github.com/espressif/esptool

It works on Windows, Mac OS X, and Linux. For the official documentation, you can visit the esptool.py GitHub page.
Finding the Serial Port Name
Connect your board to your computer.
Open the Arduino IDE.

Go to Tools > Port.
Save your ESP8266 serial port name (in our case it's COM4)
Close your Arduino IDE software.

cf: https://randomnerdtutorials.com/flashing-micropython-firmware-esptool-py-esp32-esp8266/

Installing esptool.py in your computer

To work with esptool.py, you’ll need either Python 2.7, Python 3.4 or a newer Python installation on your system. We recommend using Python 3.7.X, so go to Python’s website and install it in your computer.
With Python 3 installed, open a Terminal window and install the latest stable esptool.py release with pip:
pip install esptool

Microsoft Windows [Version 6.1.7601]
Copyright (c) 2009 Microsoft Corporation. Alle Rechte vorbehalten.

C:\Users\Kasper>pip install esptool
Collecting esptool
  Downloading https://files.pythonhosted.org/packages/6c/bf/578443af2270ebeff78f
dfd30cef3a02433cc63b34a912936653a48526dd/esptool-2.7.tar.gz (83kB)
    100% |████████████████████████████████| 92kB 1.7MB/s
Collecting pyserial>=3.0 (from esptool)
  Downloading https://files.pythonhosted.org/packages/0d/e4/2a744dd9e3be04a0c090
7414e2a01a7c88bb3915cbe3c8cc06e209f59c30/pyserial-3.4-py2.py3-none-any.whl (193k
    100% |████████████████████████████████| 194kB 4.3MB/s
Collecting pyaes (from esptool)
  Downloading https://files.pythonhosted.org/packages/44/66/2c17bae31c9066137957
Collecting ecdsa (from esptool)
  Downloading https://files.pythonhosted.org/packages/23/a8/8aa68e70959e1287da91
54e5164bb8bd5dd7025e41ae54e8d177b8d165c9/ecdsa-0.13.2-py2.py3-none-any.whl (59kB
    100% |████████████████████████████████| 61kB 7.7MB/s
Installing collected packages: pyserial, pyaes, ecdsa, esptool
Could not install packages due to an EnvironmentError: [WinError 5] Zugriff verw
eigert: 'c:\\program files\\python37\\Lib\\site-packages\\pyserial-3.4.dist-info
Consider using the `--user` option or check the permissions.
	You are using pip version 10.0.1, however version 19.2.3 is available.
You should consider upgrading via the 'python -m pip install --upgrade pip' comm

run into user permission issues i guess ... 

allways thought that i have admin-rights on this machine!?

any idea 

Share this post

Link to post
Share on other sites
5 hours ago, dil_bert said:




update:  finally were have moved one big big step forwards

 well we had three options  

this way - with the using-micropython-on-an-esp8266-with-upycraft


this way: esp_tool via github 

and this way Learn to use MicroPython on a NodeMCU ESP8266 through uPyCraft with an LED sample code.

reports here: https://forum.micropython.org/viewtopic.php?f=2&t=6941&p=39462#p39462

finally it worked with this one we have had sucess ESP8266-Flasher :: ESP-IDF

it was working like a charme 

we took this esp: (and i see that this is the wrong one - ) 


Detecting chip type... ESP8266
Chip is ESP8266EX
Uploading stub...
Running stub...
Stub running...
Configuring flash size...
Auto-detected Flash size: 4MB
Erasing flash (this may take a while)...
Chip erase completed successfully in 13.2s
Flash params set to 0x0040
Compressed 1281760 bytes to 785761...
Wrote 1281760 bytes (785761 compressed) at 0x00000000 in 70.7 seconds (effective 145.1 kbit/s)...
Hash of data verified.

note i will have to try another than this esp: (and i see that this is the wrong one - ) 


i will try out later the week and will come back and report all the findings. 

have a great day 

note - i am so lucky that i have had a little success ;)




Edited by dil_bert

Share this post

Link to post
Share on other sites

hello and good day 

_ after having tried some thing - the biest just started to work .

serial allready opened ... and i guess that i have managed to connect to the board and to work on it. 

btw: i have in the device folder 

but no main folder (guess that this will be loaded with my first script) 

see the attached image to see that all is woriking now at least regarding this tutorial 


have a great day. 


btw. where to download the newest v ersion of uPCraft - i have running version 1.0 
and besides that: i have mused and thougtht that it wold be  a good idea to get other IDEs working with the ESP such as 


but do i need to install the ArduinoIDE too !? 
love to hear from you 


Share this post

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.