Jump to content
#StayAtHome ×
Vidan

Problem with Xampp local Server

Recommended Posts

Hi to all,

I got a school program online, but I could not browse it through the program (Xampp ) local server, although I knew the database on the server in the PHP addiction, according to what I got from one of the videos, but it did not work! Any help, please

I attach to you the pictures that I receive from the program,

and this is the link for the SchoolApp:

http://www.mediafire.com/folder/iun5pgypnmcc5/schoolapp

 

1.jpg

2.jpg

3.jpg

4.jpg

Share this post


Link to post
Share on other sites

You probably won't get a whole lot of help if people have to download something from Mediafire...

Are you sure that /auth/login is the right path? Is the PHP stuff set up properly? Are there other students or teachers (you know, people who've worked with this) who might know what's wrong?

Share this post


Link to post
Share on other sites

based on the http error page, you are doing this on Windows. the .htaccess file is not keeping the leading dot when downloaded. you need to rename/copy the contents of the htaccess file to a file named .htaccess (with a leading dot.) this should allow the requested URL to get rewritten and should work.

Share this post


Link to post
Share on other sites

thank you for your help

i tried to copy all the contents inside the file to another file name (.htaccess) but also not working !

what shall i do now ?

 

Untitled-1.jpg

Untitled-2.jpg

Share this post


Link to post
Share on other sites

this is the index.php codes:

 

<?php

use FR_MO\Lib\MainController;
use FR_MO\Lib\Template\Template;
use FR_MO\Lib\Registry;
use FR_MO\Lib\SessionManager;
use FR_MO\Lib\Messenger;
use FR_MO\Lib\Authentination;

//echo

defined("DS") ? null : define("DS", DIRECTORY_SEPARATOR);

require_once 'app' . DS . 'config' . DS . 'config.php';
require_once 'config.php';
require_once APP_PATH . DS . 'lib' . DS . 'autoload.php';
$nameTemplate = require_once 'app' . DS . 'config' . DS . 'templateconfig.php';

$session = new SessionManager();
$session->start();

$messenger = Messenger::getInstance($session);

$authentination = Authentination::getInstance($session);
$template = new Template($nameTemplate);

$registry = Registry::getInstance();
$registry->session = $session;
$registry->messenger = $messenger;

$control = new MainController($template, $registry, $authentination);
$control->getInstance();

Share this post


Link to post
Share on other sites

and this is the config.php codes :

<?php

defined('DATABASE_HOST_NAME')        ? null  : define('DATABASE_HOST_NAME', 'localhost');
defined('DATABASE_USER_NAME')        ? null  : define('DATABASE_USER_NAME', 'root');
defined('DATABASE_PASSWORD')         ? null  : define('DATABASE_PASSWORD', 'Moa_09195');
defined('DATABASE_DB_NAME')          ? null  : define('DATABASE_DB_NAME', 'school_db');
defined('DOMAIN_NAME')               ? null  : define('DOMAIN_NAME', 'school.app');

 

Share this post


Link to post
Share on other sites
Posted (edited)

when i write : localhost\shoolapp

they put this : http://localhost/auth/login

!!!

 

and this is the .htaccess file contents :

RewriteEngine On

RewriteCond %{REQUEST_FILENAME} !-f

RewriteCond %{REQUEST_FILENAME} !-d

RewriteRule ^(.*)$  index.php

Edited by Vidan

Share this post


Link to post
Share on other sites

i tried now, but same problem :

i add : http://localhost/schoolApp-master/auth/login.

 

but they give me :  http://localhost/auth/login

 

Object not found!

The requested URL was not found on this server. If you entered the URL manually please check your spelling and try again.

If you think this is a server error, please contact the webmaster.

Error 404

localhost
Apache/2.4.41 (Win64) OpenSSL/1.1.1c PHP/7.3.14

Share this post


Link to post
Share on other sites

If you insist on using /auth/login then go back over the installation instructions to see what you missed.

Share this post


Link to post
Share on other sites
Posted (edited)

No dear, i am not insist to do that ! i write this : Localhost/SchoolApp-master   only     then when i click enter  automatically show me in the address this : localhost/auth/login

not me !!

you can try by your self i put the program on this link : http://www.mediafire.com/folder/iun5pgypnmcc5/schoolapp

any help ?

Edited by Vidan

Share this post


Link to post
Share on other sites

Go back over the installation instructions to see what you missed. For example, you may have missed where it said that you extract whatever source you had into htdocs directly and not inside a subfolder.

Share this post


Link to post
Share on other sites

My Friend, there is no missing into folder htdocs

there is schoolApp-master folder inside the htdocs directly

must working when i wirte : Localhost/SchoolApp-master

but not working i don't know why !

you can download the folder from this link :

http://www.mediafire.com/folder/iun5pgypnmcc5/schoolapp

and you can see what is the problem please

thank you

 

Share this post


Link to post
Share on other sites

Hello Everybody,

i still have this problem, Any Help please ?

Share this post


Link to post
Share on other sites

Either you did not follow the instructions correctly and you extracted the files to the wrong place, or the instructions are wrong and you need to contact whoever wrote them to fix them.

Beyond that, I told you what to do.

  • Like 1

Share this post


Link to post
Share on other sites

My guess is your XAMP configuration is pointing to the wrong folder for Document Root.

Looking at your File System image, I see a folder named "public". This is often the name of the document root. Perhaps your AMP configuration is pointing to SchoolApp-master when it should be pointing to SchoolApp-master/public.

In the public folder there should be an index.php file and a .htaccess file. There is probably also a folder in there called auth.

  • Like 1

Share this post


Link to post
Share on other sites

Thank you Guys

I will try to fix all the steps from the beginning

thanks.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.