Jump to content
Sign in to follow this  
dil_bert

prerequesites for installing Anaconda on a Asus Notebook that runs MX-Linux

Recommended Posts

hello daer all 


well i run MX-Linux Version 19.1 on a notebook  of the following type: asus k 54 l see https://www.ass.com/Laptops/X54L/

according the install-instructions here https://docs.anaconda.com/anaconda/install/linux/


we have to do certain steps in order to install Anaconda on the system:

Installing on Linux

Prerequisites

To use GUI packages with Linux, you will need to install the following extended dependencies for Qt:

Debian    apt-get install libgl1-mesa-glx libegl1-mesa libxrandr2 libxrandr2 libxss1 libxcursor1 libxcomposite1 libasound2 libxi6 libxtst6
RedHat    yum install libXcomposite libXcursor libXi libXtst libXrandr alsa-lib mesa-libEGL libXdamage mesa-libGL libXScrnSaver
ArchLinux    pacman -Sy libxau libxi libxss libxtst libxcursor libxcomposite libxdamage libxfixes libxrandr libxrender mesa-libgl  alsa-lib libglvnd
OpenSuse/SLES    zypper install libXcomposite1 libXi6 libXext6 libXau6 libX11-6 libXrandr2 libXrender1 libXss1 libXtst6 libXdamage1 libXcursor1 libxcb1 libasound2  libX11-xcb1 Mesa-libGL1 Mesa-libEGL1
Gentoo    emerge x11-libs/libXau x11-libs/libxcb x11-libs/libX11 x11-libs/libXext x11-libs/libXfixes x11-libs/libXrender x11-libs/libXi x11-libs/libXcomposite x11-libs/libXrandr x11-libs/libXcursor x11-libs/libXdamage x11-libs/libXScrnSaver x11-libs/libXtst media-libs/alsa-lib media-libs/mesa


The question is - is this the only way to install the Anaconda on the MX-Linux box: 

note i allready downloaded the Anaconda from the webpage  and followed this steps here

https://problemsolvingwithpython.com/01-Orientation/01.05-Installing-Anaconda-on-Linux/


5. Run the bash script to install Anaconda3

With the bash installer script downloaded, run the .sh script to install Anaconda3. Ensure you are in the directory where the installer script downloaded:

$ ls

Anaconda3-5.2.0-Linux-x86_64.sh
Run the installer script with bash.

$ bash Anaconda3-5.2.0-Linux-x86_64.sh

but see what i have gotten 

(base) martin@mx:~/Downloads
$ wget https://repo.continuum.io/archive/Anaconda3.sh
--2020-05-08 16:31:32--  https://repo.continuum.io/archive/Anaconda3.sh
Auflösen des Hostnamens repo.continuum.io (repo.continuum.io)… 2606:4700::6812:c94f, 2606:4700::6812:c84f, 104.18.201.79, ...
Verbindungsaufbau zu repo.continuum.io (repo.continuum.io)|2606:4700::6812:c94f|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 301 Moved Permanently
Platz: https://repo.anaconda.com/archive/Anaconda3.sh [folgend]
--2020-05-08 16:31:32--  https://repo.anaconda.com/archive/Anaconda3.sh
Auflösen des Hostnamens repo.anaconda.com (repo.anaconda.com)… 2606:4700::6810:8203, 2606:4700::6810:8303, 104.16.130.3, ...
Verbindungsaufbau zu repo.anaconda.com (repo.anaconda.com)|2606:4700::6810:8203|:443 … verbunden.
HTTP-Anforderung gesendet, auf Antwort wird gewartet … 404 Not Found
2020-05-08 16:31:32 FEHLER 404: Not Found.
(base) martin@mx:~/Downloads
$ https://repo.continuum.io/archive/Anaconda3<release>.sh
bash: release: Datei oder Verzeichnis nicht gefunden
(base) martin@mx:~/Downloads
$ ls
'Anaconda3-2020.02-Linux-x86_64 (1).sh'   Anaconda3-2020.02-Linux-x86_64.sh
(base) martin@mx:~/Downloads
$ bash Anaconda3-2020.02-Linux-x86_64
bash: Anaconda3-2020.02-Linux-x86_64: Datei oder Verzeichnis nicht gefunden
(base) martin@mx:~/Downloads
$ 
	

weil at the moment i try to make up my mind - where  to start into the installation - perhaps i do need some more of the prerequisites

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Sign in to follow this  

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.