Jump to content

Recommended Posts

I just installed Ubuntu 20.04. Via command line, what's the best way to install/activate PHP 7.4:

This way?
simply type "apt install php"

Or this way?
type these commands:
apt -y install software-properties-common
add-apt-repository ppa:ondrej/php
apt-get update
apt install php7.4

Share this post


Link to post
Share on other sites

Given that Ubuntu Focal (20.04) uses PHP 7.4, installing it through apt will be easiest.

That's the sort of thing you could probably have figured out yourself.

Share this post


Link to post
Share on other sites

Ya, I did :-)

I am loving Ubuntu, on my first-ever VPS. Even though I don't know what I'm doing, having total administrative control on a VPS is fun!

However, being able to view server access logs is scary! I didn't realize that every single minute (especially at night) there are dozens of probes and attempted logins happening all the time.... is this normal?

Share this post


Link to post
Share on other sites
3 hours ago, StevenOliver said:

However, being able to view server access logs is scary! I didn't realize that every single minute (especially at night) there are dozens of probes and attempted logins happening all the time.... is this normal?

Yeah. Firewall off everything you can as strictly as you can, and use non-standard ports for private services like SSH.

Share this post


Link to post
Share on other sites

Okay, I just now changed the default SSH port in sshd_config on both my identically configured Ubuntu 20.04 servers.

ssh -p 1234 user@example.com works perfect on Server #1.

Server #2 won't allow me to connect (ssh times out).

why why why WHY!

On one hand, this is fun -- it gives me something to work on for the next 100 hours... On the other hand, it's frustrating, I have other fun things I want to do (like monkey with installing an email server and avoid getting blacklisted).

Both servers have firewall (UFW) disabled while I'm trying to figure out why one server works and the other doesnt....

Share this post


Link to post
Share on other sites

Nevermind, I figured it out. (And it only took me 40 minutes to figure it out, not 100 hours).

I had a secondary firewall running which I had forgotten about. 😀

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.