Jump to content

Upgrade php to 7.3 I see 7.2 in my browser


mstdmstd
 Share

Recommended Posts

Hello,
Looking at this https://www.cloudbooklet.com/how-to-install-php-7-3-on-ubuntu-18-04/ article
I try to upgrade php to 7.3 on my local Ubuntu 18

But after I run command:
sudo apt install php7.3
restyarting the OS I see in the console :

$ php -v
PHP 7.3.20-1+ubuntu18.04.1+deb.sury.org+1 (cli) (built: Jul 9 2020 16:34:09) ( NTS )


But phpinfo in the browser shows me PHP Version 7.2 :
 

PHP Version 7.2.24-0ubuntu0.18.04.6
System Linux athoe 4.15.0-112-generic #113-Ubuntu SMP Thu Jul 9 23:41:39 UTC 2020 x86_64
Build Date May 26 2020 13:09:11
Server API Apache 2.0 Handler
Virtual Directory Support disabled
Configuration File (php.ini) Path /etc/php/7.2/apache2
Loaded Configuration File /etc/php/7.2/apache2/php.ini
Scan this dir for additional .ini files /etc/php/7.2/apache2/conf.d


also I failed to open file :

sudo nano /etc/php/7.3/apache2/php.ini

as directory /etc/php/7.3/apache2 was not found
and checking the system I see :
 

root@athoe:/etc/php# ls -la
total 24
drwxr-xr-x 4 root root 4096 ����� 1 17:33 .
drwxr-xr-x 156 root root 12288 ����� 1 17:33 ..
drwxr-xr-x 5 root root 4096 ����� 5 2019 7.2
drwxr-xr-x 5 root root 4096 ����� 1 17:33 7.3
root@athoe:/etc/php# cd 7.2
root@athoe:/etc/php/7.2# ls -la
total 20
drwxr-xr-x 5 root root 4096 5 2019 .
drwxr-xr-x 4 root root 4096 1 17:33 ..
drwxr-xr-x 3 root root 4096 4 18:22 apache2
drwxr-xr-x 3 root root 4096 3 10:01 cli
drwxr-xr-x 2 root root 409613 2020 mods-available
root@athoe:/etc/php/7.2# cd ../
root@athoe:/etc/php# cd 7.3
root@athoe:/etc/php/7.3# ls -la
total 20
drwxr-xr-x 5 root root 4096 1 17:33 .
drwxr-xr-x 4 root root 4096 1 17:33 ..
drwxr-xr-x 3 root root 4096 1 17:33 cli
drwxr-xr-x 4 root root 4096 1 17:33 fpm
drwxr-xr-x 2 root root 4096 1 17:33 mods-available

I tried to run:

sudo a2dismod php7.2

sudo a2enmod php7.3

 

But I got error:

Module php7.2 disabled. 
To activate the new configuration, you need to run:
  systemctl restart apache2 
  root@athoe:/mnt/_work_sdb8/wwwroot/lar/hostels3# sudo a2enmod php7.3 
ERROR: Module php7.3 does not exist!


What did I miss in my setup ?

Thanks!
 

Link to comment
Share on other sites

This thread is more than a year old.

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.