Jump to content

Rereading an ini - remote shared environment under cPanel


Recommended Posts

How do I force the system to re-read an ini to apply the change?

My site is remotely hosted through cPanel. It is a shared resources configuration and I don't have root privilege. I do have considerable rights but not all the way down to the level of Apache administration (for instance.) IOW: I don't have privilege to restart apache in this shared hosting environment.

In this shared hosting environment the subscribers don't have access to su, sudo, service, apache2, apache2ctl

These PHP family tools/commands are available with at least --x--x--x privilege:
 lsphp, lsphp.cagefs, pear, peardev, pecl, phar.phar, php, php-cgi, php-cgi.cagefs, php-config, php.cagefs, phpize

cPanel provides these gui tools (forgive any overlap with above)
(I understand they don't necessarily apply to PHP administration)
phpMyAdmin
phpPgAdmin
PHP Pear Packages
MultiPHPManager
MultiPHP INI Editor

terminal (RHE BASH)
a GUI file manager with an editor

Background and impetus:
I'm testing a music hosting package, but for the context of this question I want to remain more general. The name is below.

I'm new at PHP but I have a few years experience as a sysadmin for other systems. That said the PHP ini files used in the music system appear to be rather straightforward and well commented.

I'd like to un-comment a line to see the affect. (no problem, I've got the rights and understand the responsibility)

Server Details:
The music server is named "Ampache" - with an "m" - It is operational but there are tweaks clearly available in the init files that would help this implementation.
Thanks

Link to comment
Share on other sites

For example:

(realizes the example is cfg not ini)

ampache.cfg.php 

; Sociable
; This turns on / off all of the "social" features of Ampache
; default is on, but if you don't care and just want music
; turn this off to disable all social features.
; DEFAULT: "true"
sociable = "true"
 

Because I would prefer 

sociable = "false"

Link to comment
Share on other sites

Yes, I have changed the cfg file. It was a different setting that would have produced an obvious result and after about a month of getting to know the system it appears to not have read the change. I made a change, removed a leading semicolon, so the system would look for a file called folder.jpg first. I've tested it repeatedly and it still goes to a service to retrieve cover art. 

Link to comment
Share on other sites

Posted (edited)

; Art Gather Order
; Simply arrange the following in the order you would like
; Ampache to search. If you want to disable one of the search
; methods simply leave it out. DB should be left as the first
; method unless you want it to overwrite what's already in the
; database
; POSSIBLE VALUES (builtins): db tags folder lastfm musicbrainz google
; POSSIBLE VALUES (plugins): Amazon,TheAudioDb,Tmdb,Omdb,Flickr
; DEFAULT: db,tags,folder,spotify,musicbrainz,lastfm,google
;art_order = "db,tags,folder,spotify,musicbrainz,lastfm,google"
art_order = "tags,folder,musicbrainz,spotify,lastfm,google"
 

I have embedded art in many of the mp3 files and my intent from step-1 was to update the DB

Edited by Daddy-o
clarification
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.