Jump to content

PHP not installed correctly?


Filip2
 Share

Go to solution Solved by Barand,

Recommended Posts

I just installed XAMP on my windws pc.

When I try to launch my index.html file, I only get this output:

Hello World";?>

This is not correct...

My index.html file consists thrse lines:

<html>
 <head>
  <title>PHP Test</title>
 </head>
 <body>
 <?php echo "<p>Hello World</p>";?>
 </body>
</html>

 

What is wrong?
Thanks in advance...

Link to comment
Share on other sites

Thanks for the solutions.
Indeed, the php-code must be in a .php file.

It works.

What I don't understand  is that I find examples on the internet wih php code included in .html files.
 

Link to comment
Share on other sites

4 minutes ago, Filip2 said:

What I don't understand  is that I find examples on the internet wih php code included in .html files.

you CAN configure the web server to treat .html (or any other extension) as a php file. the default is for only the .php extension.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.