Jump to content

Archived

This topic is now archived and is closed to further replies.

Ryyo

Apache 2.0: server running, but no luck loading pages

Recommended Posts

Howdy all,

 

I am very much an apache newb, so any help you could provide would be much obliged.

 

I have a fresh install of Apache 2.0 on a freebsd box. When I try \"apachectl start\" I get the following message:

 

blahblah# bin/apachectl start

httpd (pid 806) already running

 

Now, \"apachectl status\" returns:

 

Looking up localhost

localhost

Making HTTP connection to localhost

Alert!: Unable to connect to remote host.

 

lynx: Can\'t access startfile http: / / localhost/server-status

 

Unofortunately, I\'m not really sure what this means, though it seems clear that being unable to connect to the remote host is my issue. Any help you could provide would be much obliged!

 

-Ryyo

Share this post


Link to post
Share on other sites

i have not worked with freebsd. i know when i started with redhat it was configured with apache and already running. i had to shut it down and edit all of the rc scripts... could this be the case with freebsd? i\'m not sure of the free bsd process syntax, trying running:

 

ps -aux | grep http

ps -elf | grep http

 

and see if anything shows up.

 

have you tried viewing just //localhost ? apache may not be configured to allow the server-status extension.

Share this post


Link to post
Share on other sites

Nope, I\'m afraid nothing came up for either of those. I now know that my IP and hostname are correct, yet still I cannot load pages.

 

When I try \"apachectl start\" with my normal login, it tells me that it cannot bind port 80. However, when I execute \"apachectl start\" in sudo, after a restrart, it just returns another commnand line, and if typed again, it will tell me \"httpd (pid 783) already running\".

 

Can anyone give me a quick synopsis on how binding ports works in unix? I guess I need to check that port 80 is open. Another odd symptom is that at one point I could FTP to this machine, but now I cannot. I haven\'t changed any FTP settings that I know of, so I am rather confused as to what has happened. Thanks for your time,

 

Ryyo

Share this post


Link to post
Share on other sites

check the Listen directive in the httpd.conf, what\'s there? also, are you logged in as root? there is another file to check that has escaped me at the moment... i\'ll keep trying. lastly, as root, try telnet 127.0.0.1 80 and see what happens... if it works use the escape character (ctrl+]) and then type \'close\'

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.