Jump to content

Connection to `ssl://pecl.php.net:443' failed:

Recommended Posts

Ok, finally figured out what I needed to do in order to install the dio.so extension and that succeeded. Updated both php.ini (web and cli) to load extension dio.so

I created a test file with the following contents:


$fd = dio_open('/dev/ttyUSB0', O_RDWR | O_NOCTTY | O_NONBLOCK);


Now, when I run it, I receive the following error:


PHP Warning:  PHP Startup: Unable to load dynamic library 'dio.so[PHP]' (tried: /usr/lib/php/20180731/dio.so[PHP] (/usr/lib/php/20180731/dio.so[PHP]: cannot open shared object file: No such file or directory), /usr/lib/php/20180731/dio.so[PHP].so (/usr/lib/php/20180731/dio.so[PHP].so: cannot open shared object file: No such file or directory)) in Unknown on line 0

I have checked /usr/lib/php and it IS there:


root@mypi:/var/www/html/WebRCP# ls /usr/lib/php/20180731/
build        curl.so  fileinfo.so  iconv.so     mysqlnd.so    phar.so      simplexml.so  sysvshm.so    xmlreader.so
bz2.so       dio.so   ftp.so       json.so      opcache.so    posix.so     sockets.so    tokenizer.so  xmlwriter.so
calendar.so  dom.so   gd.so        mbstring.so  pdo.so        readline.so  sysvmsg.so    wddx.so       xsl.so



Edited by KenHorse
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.