Jump to content

error "Your requirements could not be resolved to an installable set of packages." in laravel 8


ali_254
 Share

Recommended Posts

Posted (edited)

Hi, I downloaded a project from GitHub.

When I execute "composer update" command , I get the following error:

Your requirements could not be resolved to an installable set of packages

please guide me

Edited by ali_254
Link to comment
Share on other sites

  • ali_254 changed the title to error "Your requirements could not be resolved to an installable set of packages." in laravel 8

Your requirements could not be resolved to an installable set of packages.

  Problem 1
    - Root composer.json requires php ^7.2 but your php version (8.1.0) does not satisfy that requirement.
  Problem 2
    - laravel/passport[v8.3.0, ..., 8.x-dev] require php ^7.2 -> your php version (8.1.0) does not satisfy that requirement.
    - Root composer.json requires laravel/passport ^8.3 -> satisfiable by laravel/passport[v8.3.0, ..., 8.x-dev].

Link to comment
Share on other sites

Your composer.json says it needs to use PHP ^7.2, meaning 7.2 or 7.3 or 7.4. laravel/passport needs ^7.2 as well.

So downgrade your version of PHP to 7.2/7.3/7.4, or update your composer.json and laravel/passport dependency such that you can use PHP 8.1 with it.

  • Like 1
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.