Jump to content

Archived

This topic is now archived and is closed to further replies.

BSOD2600

Faulting application w3wp.exe

Recommended Posts

In the past four days I've noticed that my Win2K3 web server is having issues. Looking in the event log, I see: [i]Faulting application w3wp.exe, version 6.0.3790.1830, faulting module php4isapi.dll, version 0.0.0.0, fault address 0x00002443.[/i]

I downloaded Microsofts beta DebugDiag and it caught php4isapi.dll crashing. I got IISState to capture it crashing (pain in the butt too since I had to catch the new w3wp.exe process that was created). Here is the log... so now what?
[code]
IIS has crashed...
Beginning Analysis
*** WARNING: Unable to verify checksum for C:\php\sapi\php4isapi.dll
*** ERROR: Symbol file could not be found.  Defaulted to export symbols for C:\php\sapi\php4isapi.dll -
DLL (!FunctionName) that failed: php4isapi!HttpExtensionProc

Thread ID: 9
System Thread ID: e08
Kernel Time: 0:0:0.150
User Time: 0:0:0.660
Thread Type: HTTP Compression Thread
# ChildEBP RetAddr  
WARNING: Stack unwind information not available. Following frames may be wrong.
00 00f0ecb4 5a322991 php4isapi!HttpExtensionProc+0x653
01 00f0ecd4 5a3968ff w3isapi!ProcessIsapiRequest+0x214
02 00f0ed08 5a3967e0 w3core!W3_ISAPI_HANDLER::IsapiDoWork+0x3fd
03 00f0ed28 5a396764 w3core!W3_ISAPI_HANDLER::DoWork+0xb0
04 00f0ed48 5a3966f4 w3core!W3_HANDLER::MainDoWork+0x16e
05 00f0ed58 5a3966ae w3core!W3_CONTEXT::ExecuteCurrentHandler+0x53
06 00f0ed74 5a3c0a52 w3core!W3_CONTEXT::ExecuteHandler+0x51
07 00f0f01c 5a3c41d9 w3core!W3_CONTEXT::ExecuteChildRequest+0x29d
08 00f0fb74 5a3c427a w3core!W3_STATIC_FILE_HANDLER::HandleDefaultLoad+0  x5cc
09 00f0fba8 5a3c4cf2 w3core!W3_STATIC_FILE_HANDLER::DirectoryDoWork+0x5  5
0a 00f0fbcc 5a3c53f8 w3core!W3_STATIC_FILE_HANDLER::RealDoWork+0x113
0b 00f0fe78 5a396764 w3core!W3_STATIC_FILE_HANDLER::DoWork+0x368
0c 00f0fe98 5a3966f4 w3core!W3_HANDLER::MainDoWork+0x16e
0d 00f0fea8 5a3966ae w3core!W3_CONTEXT::ExecuteCurrentHandler+0x53
0e 00f0fec4 5a396648 w3core!W3_CONTEXT::ExecuteHandler+0x51
0f 00f0feec 5a392264 w3core!W3_STATE_HANDLE_REQUEST::DoWork+0x9a
10 00f0ff10 5a3965ea w3core!W3_MAIN_CONTEXT::DoWork+0xa6
11 00f0ff2c 5a36169f w3core!W3_MAIN_CONTEXT::OnNewRequest+0x55
12 00f0ff38 5a361650 w3dt!UL_NATIVE_REQUEST::DoStateProcess+0x48
13 00f0ff48 5a3616ca w3dt!UL_NATIVE_REQUEST::DoWork+0x7f
14 00f0ff5c 5a3024de w3dt!OverlappedCompletionRoutine+0x1a
15 00f0ff8c 5a3026bc W3TP!THREAD_POOL_DATA::ThreadPoolThread+0x73
16 00f0ffa0 5a301db9 W3TP!THREAD_POOL_DATA::ThreadPoolThread+0x24
17 00f0ffb8 77e66063 W3TP!THREAD_MANAGER::ThreadManagerThread+0x39
18 00f0ffec 00000000 kernel32!BaseThreadStart+0x34
[/code]

The PHP script that just started to break can be found here: [a href=\"http://www.audioscrobbler.net/wiki/RecentlyPlayedImageV2\" target=\"_blank\"]http://www.audioscrobbler.net/wiki/RecentlyPlayedImageV2[/a]. I know the script works because I just tried it on my XP Pro IIS box. I'm also running Cacti (www.cacti.net) which is PHP based and it works fine.

Any ideas why the single PHP script I try to run crashes the WWW service? How can I debug this problem?

Share this post


Link to post
Share on other sites
Bah!! Damn PHP... Found my problem, PHP 4.4.2! [a href=\"http://bugs.php.net/bug.php?id=36048&edit=1\" target=\"_blank\"]http://bugs.php.net/bug.php?id=36048&edit=1[/a]

Going back to 4.4.1 fixed it.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.