Jump to content

Archived

This topic is now archived and is closed to further replies.

wraith

having problem with "LOAD_FILE("...")" c

Recommended Posts

The problem is as follows :

 

How to get the LOAD_FILE() command to work in a .php script?

 

I have tested the command itself in mySQL and it works fine. (I am trying to import a .txt file into one field of a table)

I have used the command as follows :

 

INSERT INTO common VALUES

(1, 1, LOAD_FILE(\"e:\\1.txt\"), NULL, \'N\');

and it worked the way i wanted it - so there can\'t be any problems with the database itself.

 

Then I tried to use the same command in a php script :

 

$address = \"e:\\\\1.txt\";

$load_file = \"INSERT INTO common VALUES

(\'$row[$x]\',$user\',LOAD_FILE(\"$address\"),\'NULL\',\'N\')\";

$result = mysql_query($load_file);

 

then the page containing the script reloads for quite a long time, and when I check mySQL what actually happened I get the output :

 

1,1,NULL,NULL,N

 

WHAT\'S WRONG WITH THE SCRIPT???

the command in mySQL imports the data correctly, the script fails to do so.

HEEEEEELP!!!!

Share this post


Link to post
Share on other sites

Okay ... the thing seems to work now.

 

The problem seems to be too long file names!

 

I was using names like \"keywords_182398741.txt\"

when I changed the name to \"1.txt\" it worked all right!

 

 

 

 

Is there any limit to how long a file name can be (for mySQL to handle) ?

wraith

Share this post


Link to post
Share on other sites

It seems that the length of the files doesn\'t create any problems...

it\'s the \"_\" in the filename that crashed the whole thing.

 

 

 

PS.

could some1 pls reply? I\'m feeling like a loony posting re\'s to my own letter!

Share this post


Link to post
Share on other sites

Seemed like you fix your problem, and maybe educated someone who may run accross the same one. Good Job.

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.