Jump to content

Archived

This topic is now archived and is closed to further replies.

Zergman

Site moved servers...having issues

Recommended Posts

k, here's the story. I have a php/mysql website on a server that is working fine. I built a new server and have apache/php and mysql up and running. The database is transferred over as well with the site.

The database name is exactly the same as well with the site folder/location. Everything is pretty much the exact same.

When I access the site, it loads perfectly, but when I try to login to the site, it doesn't work. It bascially shows that my username/password is incorrect but I know they are right. I move back to the origional server and it works. The login in done with php with mysql.

To test the site/server, I created a basic page that pulled some info from the database. Works fine.

I scanned through the code on the pages looking for server reference, but I can't find nothing that would cause it not to work. I have even copied over my httpd.conf file, but no go.

Server is a fedora core 3.

Any ideas?

Share this post


Link to post
Share on other sites
Most likely culprit - old server php has register_globals OFF and new server has register_globals ON. You can check both easily by comparing the results of phpinfo() on each.

Share this post


Link to post
Share on other sites
[!--quoteo(post=345303:date=Feb 13 2006, 01:21 AM:name=AndyB)--][div class=\'quotetop\']QUOTE(AndyB @ Feb 13 2006, 01:21 AM) [snapback]345303[/snapback][/div][div class=\'quotemain\'][!--quotec--]
Most likely culprit - old server php has register_globals OFF and new server has register_globals ON. You can check both easily by comparing the results of phpinfo() on each.
[/quote]

funny story.....so I take your advise and check the php.ini file. Needless to say it was set to off. So I change it to on, reboot the server and run the phpinfo() again....>STILL OFF!.

Check the file again and its on. Well, I fight and fight for hours and can't get it on.....STILL SAYS OFF!

So I get my uber haXor friend to have a peek and see why register_globals are still off when the file says on. he comes back and says I edited the wrong line. I changed the comment line on line 25. He said look at line 380. OFF!

Changed that line and now its working just fine.

Thanks AndyB for the help!..you were dead on!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.