Jump to content

Archived

This topic is now archived and is closed to further replies.

mark_aok

Local ip is not DNS registered, how do I fix this? plz help!

Recommended Posts

Hey everyone I am on a network and my local ip is 192.168.1.106. I am trying to run apache 2 on RedHat Linux and I am having some problems starting it, 2 of them.

 

1.) First of all I am getting this error....

[Thu Apr 17 17:25:35 2003] [alert] (22002)Name or service not known: mod_unique_id: unable to find IPv4 address of \"dhcppc1\"

Configuration Failed

 

I understand that dhcppc1 is not a dns name so mod_unique_id is mad and not working, but I have this set...

ServerName 192.168.1.106:80

UseCanonicalName on

 

How do I change this dhcppc1 thing, is there a way I can make that my ip???

 

2.) My server starts fine, but nothing can be accessed so I tried restarting the server, but it cant because it cant find the httpd.pid file, this does not exist, should I create it? and If show what should I put in it???

 

 

-Thanks in advance

-Mark

Share this post


Link to post
Share on other sites

I don\'t think you can create the pid file because it is automatically created when apache starts. I could be wrong.

Does your machine has a static IP address or you are using DHCP? do ifconfig to see if your ip address changed or not or is it still the same. Can you access your server with http://localhost?

 

Jake

Share this post


Link to post
Share on other sites

No, I cannot access my server whatsoever, I think it is because of this error, it doesn\'t know where to route the files...

 

Below is the result from ifconfig, but my ipadress never changes externally, but my internal one (192.168.1.106) does. But do you know anything about how I change it so It knows that my ip is 192.168.1.106 ??? The module\'s dns is messing up I think...

i did IFCONFIG, here\'s what I got,

 

eth0 Link encap:Ethernet HWaddr 00:10:B5:83:BB:6B

inet addr:192.168.1.106 Bcast:192.168.1.255 Mask:255.255.255.0

UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1

RX packets:457 errors:0 dropped:0 overruns:0 frame:0

TX packets:480 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:100

RX bytes:271423 (265.0 Kb) TX bytes:126257 (123.2 Kb)

Interrupt:11 Base address:0x6000

 

lo Link encap:Local Loopback

inet addr:127.0.0.1 Mask:255.0.0.0

UP LOOPBACK RUNNING MTU:16436 Metric:1

RX packets:136 errors:0 dropped:0 overruns:0 frame:0

TX packets:136 errors:0 dropped:0 overruns:0 carrier:0

collisions:0 txqueuelen:0

RX bytes:8776 (8.5 Kb) TX bytes:8776 (8.5 Kb)

Share this post


Link to post
Share on other sites

I would try this, in your httpd.conf file don\'t specify any ip address, just do - Listen 80. So, it will listen to all ip addresses that are available. Then if you can start apache, try accessing with localhost on the server. If you are accessing it from a different machine, first see if you can ping that ip address.

I don\'t know if this will help you, your network configuration is unclear to me. I assume you have a static public IP and you are using private ip for your network using dhcp. you should use a static ip for you apache server.

 

Hope it helps.

Jake

Share this post


Link to post
Share on other sites

same problem it is giving me the same error.....

 

It\'s not about allowing ip\'s its about telling this stupid thing that my ip isn\'t dhcppc1 so that it knows that that isn\'t supposed to be a \"valid dns name\", no matter what I try it keeps telling me that dhcppc1 is\'nt supposed to be a domain name.

 

It says configuration failed, and without the config file apache cannot launch, that is the problem, but I have no idea how to set the ip in Linux, anyone have any ideas?

Share this post


Link to post
Share on other sites

have you tried UseCanonicalName Off? what is your ServerName directive set to?

Share this post


Link to post
Share on other sites

Yup with the canonical thing, I tried it on, and off and it still gives me the exact same error...........

 

[Thu Apr 17 19:15:17 2003] [alert] (22002)Name or service not known: mod_unique_id: unable to find IPv4 address of \"dhcppc1\"

Configuration Failed

 

It\'s not configuring thus apache cannot run, I think I found another thing that might be the cause of this pathetic error, the hosts file - /etc/hosts

 

Here is what is says

 

# Do not remove the following line, or various programs

# that require network functionality will fail.

127.0.0.1 localhost.localdomain localhost

 

 

If anyone knows how to tell it that dhcppc1 is not supposed to be looked up as a dns name plz help,

 

-Mark

Share this post


Link to post
Share on other sites

the hosts file is ok.

you don\'t have a ServerName set? you should... try using

 

ServerName your-external-ip:80

 

also try running ./httpd -t in apache\'s bin dir. does it say \"Syntax OK\"?

Share this post


Link to post
Share on other sites

:roll: Well I have ServerName set up and it does nothing, the spelling is right dont worry. I\'ve tried 192.168.1.106, and I\'ve tried 127.0.0.1, but every time I get the same error about dhcppc1, so I am not sure where it is getting this from...

 

 

ALSO, on the loggin screen for Redhat 8.0 it tells me that gnome cannot work pefectly because dhcppc1 is not a proper name, (dns lookup) it tells me to configure the etc/hosts file...

 

Should I add something like this??

 

dhcppc1 local host 192.168.1.106?????

I got no clue how to fix it, ServerName and conical or whatever is doing nothing, so what can I configure?? should I change the mod_unique_id.C file????

 

 

PLZ help :cry::cry:

Share this post


Link to post
Share on other sites

Thankyou so much!!!! It worked perfectly except for one little problem. When I restart Linux it hangs on sendmail, and doesn\'t let me start up, if you know anything about how to modify it plz post

 

 

-Thanks!!

Share this post


Link to post
Share on other sites

doesn\'t let you start the program, right? ...not the entire system? make sure you didn\'t delete anything from the hosts file that may have been needed... other than that i\'m not too sure. i have yet to tackle sendmail, still trying to reroute a smarthost at work... do you have a specific error message? they may be in maillog or syslog... you can also try editting the rc script for sendmail to redirect stderr.

Share this post


Link to post
Share on other sites

Well, It\'s not that it hangs, it just sort of sits there for a while, and then starts up linux. I think it is trying to get the DNS lookup for 192.168.1.106 should do something like dhcppc1.localHost or something, because in the file there was originally this localhost.localdomain localhost I\'ll talk to people at my church about this though, but thankyou so much for helping me so far efiggy, I really apreciate it, and I got apache working locally, thanks man,

 

happy easter !!!!

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.