Jump to content

Archived

This topic is now archived and is closed to further replies.

Arenium

Startig MySQL in RedHat 9

Recommended Posts

Recently bought (yeah, i wanted the stickers :wink: ) RH9 and installed it. WOOHOO! This is great so far. I installed all packages at setup and have php and apache all set. In fact, it was already taken care of, all i had to do was type $ httpd start folder! I\'m thinking it\'s just a redhat 9 thing, because i checked and the package was installed.

 

Also, when i tried to run safe_mysqld i get


Starting mysqld daemon with databases from /var/lib/mysql

030419 18:38:27  mysqld ended

 

Again, when i made a simple PHP file called mysql.php i get


Warning: Can\'t connect to local MySQL server through socket \'/var/lib/mysql/mysql.sock\' (111) in /var/www/html/mysql.php on line 2



Warning: MySQL Connection Failed: Can\'t connect to local MySQL server through socket \'/var/lib/mysql/mysql.sock\' (111) in /var/www/html/mysql.php on line 2

 

Now is it just me, or does something conflict in all these tuts im reading. In that error and in the safe_mysqld message, they both refer to /var/lib/mysql instead of /usr/local/mysql/.

This just leaves me more in the clouds. GAH!

 

Thanks in advance for any help,

 

P.S.- So far, RH9 is excellent, rock solid and found ALL drivers and hardware better than windows

Share this post


Link to post
Share on other sites

is anything under /var/lib/mysql? try and find the hostname.err file to get more information. also, look in, i think -- /etc/rc.d/init.d for a script with mysql in it\'s name, you can view it to find which directories it\'s pulling off of.

Share this post


Link to post
Share on other sites

oh man, I\'m such a newb...all i hadta do was launch it with the complete path name


/etc/init.d/mysqld start

 

OK, got it all running, now just gotta secure this puppy:

 

At the present, i can login to phpMyAdmin with root and my password to see all db\'s, BUT, i can also login with any username i choose and no password, but see no DB\'s.

 

Technically, it\'s secure, but I don\'t want ANYBODY except root to have access, how can i do this? I\'ve RTFM, meaning, the documentation included with phpMyAdmin...to no avail so far

 

help...again?[/code]

Share this post


Link to post
Share on other sites

haven\'t used the program... go into the login script and find out what the POST var is of the username...

 

[php:1:3b469317b7]

if($_POST[\'username\']!=\'root\') { exit; }

[/php:1:3b469317b7]

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.