Jump to content

Archived

This topic is now archived and is closed to further replies.

mikeu

having problem posting content

Recommended Posts

:( I am new to running a server and need some help.. I have installed apache on a linux box and and have a url all setup and running.. I am running apache 2 .. I have tried to post a static webpage. I have called it index.html and have moved it to Apache2>htdocs> folder and have reboot the box but never seams to replaced the apache \"test page\"

Thanks for any help!!! : :cry:

Share this post


Link to post
Share on other sites

hmm... make sure htdocs is your DocumentRoot in the httpd.conf. also clear your cache just in case, maybe it is working.

Share this post


Link to post
Share on other sites

I am not getting an error I have looked at the errorlog and it shows that thing are fine? That why I was wondering if I should try re-installing apache 2 ?? or am I looking at the problem all wrong?? or is there someything wrong with using redhat linux 8 and apache 2 gui?? :?:

Share this post


Link to post
Share on other sites

the server-parsed language-adjusting indexes may be set to take precedence. try putting a test.html in there and referencing it directly in the url.

Share this post


Link to post
Share on other sites

I have notice that when I add the new index.html file it does not show?? up where the the index.html file is (the one with the orig test page !!)

Share this post


Link to post
Share on other sites

quick question should I have installed the ssi mod or the cgi mod ???

Share this post


Link to post
Share on other sites

the server module is preferred over cgi.

Share this post


Link to post
Share on other sites

if I install the ssi will that take care of my problem of not being able to post content on my server???

Share this post


Link to post
Share on other sites

i cannot say for sure mike. i don\'t know the entire picture of your system, your installation, your configuration, and what you\'ve done, tried, changed, etc... if you used cgi, have you verified that the configuration matches up to the instructions on php.net? double check file permissions and the like.

Share this post


Link to post
Share on other sites

I did as you said and moved the index.htlml to the var/www/html file and now I get an error when I go to my url and so I though I would reboor the sys but now I get errors when I reboot .. the error is \"server authorization directory (deamon/serauthdir) is set to /var/gdm but this does not exist. please correct gdm configuration /etc/x11/gdm/gdm.conf and restart gdm\"

the only other thing I did was to make a copy on the var/www/html to the desktop.. :?:

Thanks for the help

Share this post


Link to post
Share on other sites

:shock: uhrm. you only moved the index.html file? only moving an html file wouldn\'t do this...

Share this post


Link to post
Share on other sites

so do you think I should reformat my harddrive an start from the scratch.

Thanks for all the help!!!

Share this post


Link to post
Share on other sites

this is a really weird situtatiion without being at your machine... is it possible to move the file back? otherwise, i guess that is the only alternative?

Share this post


Link to post
Share on other sites

×

Important Information

We have placed cookies on your device to help make this website better. You can adjust your cookie settings, otherwise we'll assume you're okay to continue.