Jump to content


Photo

Access denied for user


  • Please log in to reply
6 replies to this topic

#1 Kai

Kai
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 04 May 2003 - 11:11 PM

My database which was working perfectly yesterday now won\'t let me \"Insert data from a textfile into table\" on the SQL tab in phpMyAdmin. I get the following error:

MySQL said: 



Access denied for user: \'myusername@localhost\' (Using password: YES)


Do you think this is a transient problem since it was working yesterday?

#2 shivabharat

shivabharat
  • Members
  • PipPipPip
  • Advanced Member
  • 371 posts
  • LocationChennai, India

Posted 05 May 2003 - 04:49 PM

Does the login u used have all the rights? try to login using the super user login.
Knowledge --- Reading Enriches Mind But Sharing Enhances It.[br][br]Note: Before you request help enusre that you have had a look at the tutorials @phpfreaks

#3 Kai

Kai
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 05 May 2003 - 07:46 PM

Yup, that it is the super. I haven\'t changed anything.

#4 phpfreak

phpfreak
  • Members
  • PipPipPip
  • Advanced Member
  • 527 posts
  • LocationEverywhere!

Posted 05 May 2003 - 08:05 PM

If you haven\'t changed anything from the default installation, use the username: root and no password.

Good luck!
Eric 'phpfreak' Rosebrock
Got LAMP?
http://www.Phpfreaks.com Founder

#5 Kai

Kai
  • New Members
  • Pip
  • Newbie
  • 5 posts

Posted 05 May 2003 - 09:14 PM

Thanks :-) The thing is it doesn\'t ask me for my username or pwd at any point. I log into cPanel with my normal site username and pwd, go to phpmyadmin, click on the database I want and the table I want, all as usual. I click on SQL and \"Insert data into table from text file\" and pop the same options in I normally do. Then I click insert and I get that error.

I\'m not really sure what\'s going on... I might try deleting my cookies to see if refreshing them helps...

Edit - nope didn\'t help.

#6 shivabharat

shivabharat
  • Members
  • PipPipPip
  • Advanced Member
  • 371 posts
  • LocationChennai, India

Posted 05 May 2003 - 09:22 PM

Try to change the authentictaion mode in the

config.inc.php

read documentation for more details

phpMyAdmin/Documentation.html#config

Knowledge --- Reading Enriches Mind But Sharing Enhances It.[br][br]Note: Before you request help enusre that you have had a look at the tutorials @phpfreaks

#7 phpfreak

phpfreak
  • Members
  • PipPipPip
  • Advanced Member
  • 527 posts
  • LocationEverywhere!

Posted 05 May 2003 - 09:29 PM

If you are using CPanel, I would contact your web hosting provider and ask them what the username and password is. Chances are, it\'s the same as your login. It might be username@domain.name for the username and your CPanel password.
Eric 'phpfreak' Rosebrock
Got LAMP?
http://www.Phpfreaks.com Founder




0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users